СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 7458

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 33

N = 1

WHILE S > 0

S = S – 7

N = N * 3

WEND

PRINT(N)

s = 33

n = 1

while s > 0:

    s = s - 7

    n = n * 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 33;

n := 1;

while s > 0 do

begin

s := s – 7;

n := n * 3

end;

writeln(n)

end.

нач

цел s, n

s := 33

n := 1

нц пока s > 0

s := s – 7

n := n * 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{ int s, n;

s = 33;

n = 1;

while (s > 0) {

s = s – 7;

n = n * 3;

}

cout << n << endl;

}

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие s > 0, т. е. переменная s определяет, сколько раз выполнится цикл. Поскольку изначально s = 33, цикл выполнится 5 раз, следовательно, n = 35 = 243.

 

Ответ: 243.

Источник: Демонстрационная версия ЕГЭ—2015 по информатике.