СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 7269

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 15

WHILE S <= 250

    S = S + 12

    N = N + 2

WEND

PRINT N

n = 4

s = 15

while s <= 250:

    s += 12

    n += 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 15;

    while s <= 250 do

    begin

        s := s + 12;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 4

    s := 15

    нц пока s <= 250

        s := s + 12

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 15;

    while (s <= 250) {

        s = s + 12;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Начнем анализировать программу.

1)После выполнения первого цикла s = 27, n = 6

2)s = 39, n = 8

3)s = 51, n= 10

.....

18)s = 231, n = 40

19)s = 243, n = 42

20)s = 255, n = 44 так как s > 250 следовательно, программа останавливается, значит, n = 44.