≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 7202

Определите число, которое будет напечатано в результате выполнения программы.

Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 70

WHILE S > 7

S = S – 7

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 70;

    while s > 7 do

    begin

        s := s – 7;

        i := i + 1

    end;

    writeln(i)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int i, s;

    i = 0;

    s = 70;

    while (s > 7)

    {

        s = s – 7;

        i++;

    }

    cout << i << endl ;

}

алг

нач

цел i, s

i := 0

s := 70

нц пока s > 7

    s := s - 7

    i := i + 1

кц

вывод i

кон

Python

i = 0

s = 70

while s > 7:

    s -= 7

    i += 1

print(i)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s > 7, т. е. переменная s определяет, сколько раз выполнится цикл.

Заметим, что На 9 шаге s станет равной 7 и условие s > 7 окажется невыполненным, цикл прервется. Следовательно, значение i будет равно 1·9 = 9.

 

Ответ: 9.

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.