СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 6810

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 36

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 365:

    s += 36

    n *= 2

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s ≤ 365, т. е. переменная s определяет, сколько раз выполнится цикл.

Заметим, что На 11 шаге s станет равной 396 и условие s ≤ 365 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 211 = 2048.

 

Ответ: 2048.