СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 6576

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 15

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 15;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 15;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 15

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

Python

n = 15

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие s <= 257, т. е. переменная s определяет, сколько раз выполнится цикл.

Заметим, что На 11 шаге s станет равной 275 и условие s <= 257 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 15 + 4·11 = 59.

 

Ответ: 59.

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 802.