≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 6305

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 20

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 20

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 20;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 20

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 267:

    s += 25

    n += 20

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 267, т. е. переменная s определяет, сколько раз выполнится цикл.

Заметим, что На 11 шаге s станет равной 275 и условие s <= 275 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 11·20 = 220.

 

Ответ: 220.

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 502.