≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5905

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 256

WHILE S > 0

    S = S - 25

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 256;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 3;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

void main()

{

    int n, s;

    n = 0;

    s = 256;

    while (s > 0)

    {

        s = s - 25;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 256

    нц пока s > 0

        s : = s - 25

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 256

while s > 0:

    s -= 25

    n += 3

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s > 0, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Заметим, что На 11 шаге s станет равной −19 и условие s > 0 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 11·3 = 33

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 3.