СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 5873

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S > 0

    S = S - 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 512;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 4;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s > 0)

    {

        s = s - 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 512

    нц пока s > 0

        s : = s - 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 512

while s > 0:

    s -= 25

    n += 4

print(n)

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие s > 0, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Заметим, что На 21 шаге s станет равной −13 и условие s > 0 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 21·4 = 84.

Источник: ЕГЭ по информатике 30.05.2013. Основная волна. Центр. Вариант 2.