≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5841

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 301

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 301;

    while s > 0 do

    begin

        s : = s - 10;

        n : = n + 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 301;

    while (s > 0)

    {

        s = s - 10;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 301

    нц пока s > 0

        s : = s - 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 301

while s > 0:

    s -= 10

    n += 2

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s > 0, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Заметим, что На 31 шаге s станет равной −9 и условие s > 0 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 31·2 = 62.

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 1.