СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5277

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 30

    S = 1

    WHILE S < 500

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n := 30;

    s := 1;

    while s < 500 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 1;

    while (s < 500)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 30

s : = 1

нц пока s < 500

    s := s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 30

s = 1

while s < 500:

    s *= 2

    n += 10

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 500, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Поскольку , следовательно, цикл выполнится 9 раз. На 9-м шаге s станет равной 512 и условие s < 500 окажется не выполненным, цикл прервется. Следовательно, значение n будет равно 9·10 + 30 = 120.