СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5244

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 60

S = 25

WHILE S < 365

S = S + 20

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 60;

    s : = 25;

    while s < 365 do

    begin

        s : = s + 20;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 60;

    s = 25;

    while (s < 365)

    {

        s = s + 20;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 60

s : = 25

нц пока s < 365

    s : = s + 20

    n : = n + 10

кц

вывод n

кон

Python

n = 60

s = 25

while s < 365:

    s += 20

    n += 10

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 365, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз (здесь мы учли, что начальное значение s = 25). На семнадцатом шаге s станет равной 365 и условие s < 365 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 10·17 + 60 = 230.