СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5212

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 30

S = 25

WHILE S < 425

S = S + 40

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 30;

    s : = 25;

    while s < 425 do

    begin

        s : = s + 40;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 25;

    while (s < 425)

    {

        s = s + 40;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 30

s : = 25

нц пока s < 425

    s : = s + 40

    n : = n + 10

кц

вывод n

кон

Python

n = 30

s = 25

while s < 425:

    s += 40

    n += 10

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 425, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз (здесь мы учли, что начальное значение s = 25). На десятом шаге s станет равной 425 и условие s < 425 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 10·10 + 30 = 130.