≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5088

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 26

WHILE S <= 205

    S = S + 20

    N = N * 2

WEND

PRINT N

n = 1

s = 26

while s <= 205:

    s += 20

    n *= 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 26;

    while s <= 205 do

    begin

        s := s + 20;

        n := n * 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 1

    s := 26

    нц пока s <= 205

        s := s + 20

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 1, s = 26;

    while (s <= 205) {

        s = s + 20;

        n = n * 2;

    }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 205, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Выясним сколько раз цикл выполнится: . Учитывая, что до цикла s := 26, находим, что цикл выполнится 9 раз. Значение n будет равно 29 = 512.