СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 5056

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 6

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 1;

    s : = 6;

    while s <= 365 do

    begin

        s : = s + 36;

        n : = n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 6;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 1

s : = 6

нц пока s <= 365

    s : = s + 36

    n : = n * 2

кц

вывод n

кон

Python

n = 1

s = 6

while s <= 365:

    s += 36

    n *= 2

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 365, т. е. переменная s определяет, сколько раз выполнится цикл. Цикл выполнится раз. Учитывая, что изначально s=6 и что действие "n : = n * 2" выполняется после "s : = s + 36", приходим к выводу, что действие "n : = n * 2" выполнится 10 раз. Следовательно, значение n будет равно 210 = 1024.

 

Ответ: 1024.