СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 4936

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 5

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 5

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 5;

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 5

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 365, т. е. переменная s определяет сколько раз выполнится цикл.

Сколько раз цикл выполнится?

.

Учтем, что на десятом шаге действие n := n + 5; выполнится.

Следовательно, ответ 50+5=55.