СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 4723

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 256

    s : = s + 25

    n : = n + 1

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 256:

    s += 25

    n += 1

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 256, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз. Следовательно, значение n будет равно 11.