≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 4691

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 50

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 512 do

    begin

        s := s + 50;

        n : = n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0 ;

    s = 0 ;

    while (s <= 512)

    {

        s = s + 50;

        n = n + 1;

}

cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 512

    s := s + 50

    n := n + 1

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 512:

    s += 50

    n += 1

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 512, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз (здесь мы использовали округление в меньшую сторону, поскольку при 500 цикл выполнится, а при 550 он уже выполняться не будет). Следовательно, значение n будет равно 11 (на последнем шаге к n прибавится еще одна единица и цикл прервется).