≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 4557

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 35

    N = N + 1

    S = S + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 35 do

    begin

        n := n + 1;

        s := s + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 35)

    {

        n = n + 1;

        s = s + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 35

    n := n + 1

    s := s + 4

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 35:

    n += 1

    s += 4

print(n)

 

Пояснение.

Переменная n показывает, сколько раз выполнился цикл, следовательно Однако, при n=8, s=32. Следовательно, цикл выполнится не 8, а 9 раз.

 

Ответ: 9.

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.