≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3842

Определите, что будет напечатано в результате выполнения программы

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + 15

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += 15

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + 15;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + 15

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s = s + 15;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

Пояснение.

Выпишем значения s и n:

 

s 0; 15; 30; 45; 60; 75.

 

n 4; 5; 6; 7; 8; 9.

 

Цикл закончится, когда n > 8, т.е. при n = 9. Так как действие n := n + 1 идет после действия s := s + 15,

то значение 75 будет записано в переменную s до того, как цикл прекратит работу.

 

Следовательно, ответ 75.

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 2.