≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3810

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования:

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 101

S = S + 7

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n : = 1;

    s : = 0;

    while n <= 101 do

    begin

        s : = s + 7;

        n : = n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 101)

    {

        s = s + 7;

        n = n + 1;

    }

    cout << s << endl;

}

алг

нач

цел n, s

n : = 1

s : = 0

нц пока n <= 101

    s : = s + 7

    n : = n + 1

кц

вывод s

кон

Python

n = 1

s = 0

while n <= 101:

    s += 7

    n += 1

print(s)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 101, т. е. переменная n определяет сколько раз выполнится цикл. Следовательно, формульно s можно задать как функцию n так:

 

, где а

 

, так как последняя операция, выполненная в цикле: n := 101 + 1.

 

Следовательно

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.