≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3775

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 26

    S = S + 6

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 26:

    s += 6

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 26 do

    begin

        s := s + 6;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 26

        s := s + 6

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 26) {

        s = s + 6;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 26, т. е. переменная n определяет сколько раз выполнится цикл. Следовательно, формульно s можно задать как функцию n так:

 

, где а

 

, так как последняя операция, выполненная в цикле, перед тем, как он прервется: n := 26 + 1.

 

Следовательно,