СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3774

Определите, что будет напечатано в результате выполнения программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 13

    S = S + 15

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 13:

    s += 15

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 13

        s := s + 15

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 13) {

        s = s + 15;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 13, т. е. переменная n определяет сколько раз выполнится цикл. Следовательно, формульно s можно задать как функцию n так:

 

, где а

 

, так как последняя операция, выполненная в цикле: n := 13 + 1.

 

Следовательно,