СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 25 № 3630

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на языке программирования "Паскаль" алгоритм, позволяющий найти и вывести количество элементов массива, десятичная запись которых содержит ровно 2 цифры, причём хотя бы одна из этих цифр — цифра 9.

Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них

 

ПаскальБейсик

const N=30;

Var

a:array [1..N] of integer;

i, j, k: integer;

begin

for i:=1 to N do

readln(a[i]);

end.

N=30

DIM A(N) AS INTEGER

DIM I, J, K AS INTEGER

FOR I = 1 TO N

INPUT A(I)

NEXT I …

END

Си++Алгоритмический язык

#include <iostream>

using namespace std;

#define N 30

int main(){

int a[N];

int i, j, k;

for (i=0; i<N; i++)

cin >> a[i];

...

}

алг

нач

цел N=30

целтаб a[1:N]

цел i, j, k

нц для i от 1 до N

ввод a[i]

кц

...

кон

Естественный язык
Объявляем массив A из 30 элементов.

Объявляем целочисленные переменные I, J, K.

В цикле от 1 до 30 вводим элементы массива A с 1-го по 30-й.

...

Python

# допускается также

# использовать две

# целочисленные переменные j, k

a = []

n = 30

for i in range(0, n):

a.append(int(input()))

...

 

В качестве ответа Вам необходимо привести фрагменты программы, который должен находиться на месте многоточия.

Решение.

 

Паскаль
k:=0;

for i:=1 to N do begin

if (10<=a[i]) and (a[i]<=99) and

((a[i] mod 10 = 9) or (a[i] div 10=9)) then k:=k+1;

end;

writeln(k);

Бейсик
K = 0

FOR I = 1 TO N

IF 10 <=A(I) AND A(I)<=99AND (A(I) MOD 10=9 OR A(I)\10=9)THEN

K = K + 1

END IF

NEXT I

PRINT K

СИ
k=0 ;

for (i=0; i < N; i++) {

if (10< = a[i] && a[i]< = 99 && (a[i]%10 == 9 || a[i]/10 == 9))

++k;

}

cout « k « endl;

Алгоритмический язык
k:=0

нц для I от 1 до N

если 10<=A[I]<=99 и (MOD(A[I],10)=9 или DIV(A[I],10)=9) то k:=k+1

все

кц вывод k

Естественный язык
Записываем в переменную k начальное значение, равное 0. В цикле от первого элемента до тридцатого проверяем каждый элемент. Если его значение попадает в диапазон от 10 до 99 и при этом остаток от деления элемента на 10 или целая часть частного от этого деления равны 9, то увеличиваем значение k на 1. Переходим к следующему элементу массива. После завершения цикла выводим значение переменной k.