СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3565

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 14

S = 0

WHILE N <= 18

S = S + 25

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 14;

    s := 0;

    while n <= 18 do

    begin

        s := s + 25;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 14;

    s = 0;

    while (n <= 18)

    {

        s = s + 25;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 14

s := 0

нцпока n <= 18

    s := s + 25

    n := n + 1

кц

вывод s

кон

Python

n = 14

s = 0

while n <= 18:

    s += 25

    n += 1

print(s)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 18, т. е. переменная n определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз ( "+1" потому, что в дроби мы не учитываем то, что при 18 он тоже выполнится). Следовательно, значение s будет равно 125.