≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3564

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

S = S - 20

N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 512

нцпока s >= 0

    s := s - 20

    n := n + 1

кц

вывод n

кон

Python

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s >= 0, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Так как , цикл выполнится 26 раз (так как действие "s := s - 20" выполняется до "n := n + 1", значит, до того, как цикл прервется, действие "n := n + 1" успеет выполниться). Значение n будет равно 26.