СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 3538

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

БейсикПаскаль

DIM s, k As Integer

s = 0

k = 0

WHILE k < 30

    k = k + 3

    s = s + k

END While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=0;

    while k < 30 do

    begin

        k:=k+3;

        s:=s+k;

    end;

    write(s);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=0

нц пока k < 30

    k:=k+3; s:=s+k

кц

вывод s

кон

Python

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие k < 30, т. е. переменная k определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз ( «+1» потому, что в дроби мы не учитываем нулевые значения s и k). Заметим, что в s накапливается сумма арифметической прогрессии, содержащей 11 членов, с разностью 3. Следовательно, .