СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 3529

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (за­пи­сан­ной ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния):

 

Бей­сикПас­каль

Dim s, k As Integer

s = 0

k = 1

while k < 11

    s = s + k

    k = k + 1

End While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=1;

    while k<11 do

    begin

        s:=s+k;

        k:=k+1;

    end;

    write(s);

end.

Си++Ал­го­рит­ми­че­ский язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 1;

    while (k < 11) {

        s = s + k;

        k = k + 1;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=1

нц пока k < 11

    s:=s+k; k:=k+1

кц

вывод s

кон

Python

s = 0

k = 1

while k < 11:

    s += k

    k += 1

print(s)

 

Ре­ше­ние.

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие k < 11, т. е. пе­ре­мен­ная k опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл.

 

Цикл вы­пол­нит­ся раз. За­ме­тим, что в s на­кап­ли­ва­ет­ся сумма ариф­ме­ти­че­ской про­грес­сии, со­дер­жа­щей 11 чле­нов, с раз­но­стью 1. Сле­до­ва­тель­но, .