СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3529

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

Dim s, k As Integer

s = 0

k = 1

while k < 11

    s = s + k

    k = k + 1

End While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=1;

    while k<11 do

    begin

        s:=s+k;

        k:=k+1;

    end;

    write(s);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 1;

    while (k < 11) {

        s = s + k;

        k = k + 1;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=1

нц пока k < 11

    s:=s+k; k:=k+1

кц

вывод s

кон

Python

s = 0

k = 1

while k < 11:

    s += k

    k += 1

print(s)

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие k < 11, т. е. переменная k определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз. Заметим, что в s накапливается сумма арифметической прогрессии, содержащей 11 членов, с разностью 1. Следовательно, .