СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 3513

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие n <= 8, т. е. переменная n определяет, сколько раз выполнится цикл.

 

Цикл выполнится раз ( "+1" потому, что в дроби мы не учитываем то, что при 8 он тоже выполнится).

 

Заметим, что в s накапливается сумма арифметической прогрессии из 5 членов с разностью 1. Следовательно, .