СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задания Д19 № 3379

Элементы двухмерного массива A размером NxN первоначально были равны 1000. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

k = 0

FOR i = 1 TO N

    FOR j = N-i+1 TO N

        k += 1

        A(i,j) = k

    NEXT j

NEXT i

 

k = 0

for i in range(1, n+1):

    for j in range(n-i+1, n+1):

        k = k + 1

        A[i,j] = k

 

ПаскальАлгоритмический язык

k := 0;

for i:= 1 to n do

    for j:=N-i+1 to n do begin

        k:= k + 1;

        A[i,j]:= k;

    end;

k := 0

нц для i от 1 до n

    нц для j от n-i+1 до n

        k:= k + 1

        A[i,j]:= k

    кц

кц

Си++

k = 0;

for (i = 1; i <= n; i++) {

    for (j = n-i+1; j <= n; j++) {

        k = k + 1;

        A[i][j] = k;

    }

}

 

 

Какой элемент массива в результате будет иметь минимальное значение?

 

1) A[1,1]

2) A[1,N]

3) A[N,1]

4) A[N,N]

Решение.

Отметим, что j изменяется от N до 1.

 

Оператор k:= k + 1; A[i,j]:= k; увеличивает значение элемента A[i,j] на единицу. Значит, минимальное значние будет в самом начале цикла при k=1, чему соответствует элементу A[1,N].

 

Правильный ответ указан под номером 2.