СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3254

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 512;

    while (s >= 0) {

        s = s - 20;

        n = n + 1;

    }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s >= 0, т. е. переменная s определяет, сколько раз выполнится цикл.

 

Следовательно, цикл выполнится 25 раз и еще один раз, так как операция n := n + 1 идет до проверки условия s >= 0.

 

Следовательно, ответ — 26.