СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 3254

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

Пас­кальАл­го­рит­ми­че­ский язык

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 512;

    while (s >= 0) {

        s = s - 20;

        n = n + 1;

    }

    cout << n << endl;

    return 0;

}

 

Ре­ше­ние.

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие s >= 0, т. е. пе­ре­мен­ная s опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл.

 

Сле­до­ва­тель­но, цикл вы­пол­нит­ся 25 раз и еще один раз, так как опе­ра­ция n := n + 1 идет до про­вер­ки усло­вия s >= 0.

 

Сле­до­ва­тель­но, ответ — 26.