≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3244

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 24

S = 0

WHILE N <= 28

    S = S + 20

    N = N + 2

WEND

PRINT S

n = 24

s = 0

while n <= 28:

    s += 20

    n += 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do

    begin

        s := s + 20;

        n := n + 2;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 24

    s := 0

    нц пока n <= 28

        s := s + 20

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 24, s = 0;

    while (n <= 28) {

        s = s + 20;

        n = n + 2;

    }

    cout << s << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 28, т. е. переменная n определяет, сколько раз выполнится цикл.

 

Аккуратно посчитаем, сколько раз выполниться цикл (k):

 

Значения n: 24 26 28 30.

 

Следовательно, цикл выполнится три раза (так как действие n := n + 2 стоит в конце цикла, следовательно, для n=30 действие s := s + 20 не будет выполняться).

 

Посчитаем значение s: .