≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3242

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 2

S = 35

WHILE N <= 25

    S = S + 20

    N = N + 5

WEND

PRINT S

n = 2

s = 35

while n <= 25:

    s += 20

    n += 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 2;

    s := 35;

    while n <= 25 do

    begin

        s := s + 20;

        n := n + 5;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 2

    s := 35

    нц пока n <= 25

        s := s + 20

        n := n + 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 2, s = 35;

    while (n <= 25) {

        s = s + 20;

        n = n + 5;

    }

    cout << s << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 25, т. е. переменная n определяет, сколько раз выполнится цикл.

 

Аккуратно посчитаем, сколько раз выполнится цикл(k):

 

Значения n 2 7 12 17 22 27

 

Следовательно, цикл выполнится пять раз (так как действие n := n + 5 стоит в конце цикла, следовательно, для n=27 действие s := s + 20 не будет выполняться).

 

Посчитаем значение s: