СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 15820

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 5

WHILE N > 0

S = S + N

N = N − 1

WEND

PRINT S

s = 0

n = 5

while n > 0:

    s = s + n

    n = n − 1

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 5;

    while n > 0 do

    begin

        s := s + n;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 5

    нц пока n > 0

        s := s + n

        n := n − 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 5;

    while (n > 0) {

        s = s + n;

        n = n − 1;

    }

    cout << s;

    return 0;

}

 

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие , т.е. переменная n определяет, сколько раз выполнится цикл.

Заметим, что на пятом шаге n станет равным 0 и условие окажется невыполненным, цикл while прервётся. Следовательно, значение s будет равно .

 

Ответ: 15.