СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 15130

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 1

WHILE N < 21

S = S - 1

N = N + 2

WEND

PRINT S

s = 25

n = 1

while n < 21:

    s = s - 1

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 1;

    while n < 21 do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 25

    n := 1

    нц пока n < 21

        s := s - 1

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 1;

    while (n < 21) {

        s = s - 1;

        n = n + 2;

    }

    cout << s;

    return 0;

}

 

 

Решение.

Цикл while выполняется до тех пор, пока истинно условие , т.е. переменная n определяет, сколько раз выполнится цикл.

 

Заметим, что На десятом шаге n станет равным 21 и условие окажется невыполненным, цикл while прервётся. Следовательно, значение s будет равно .

 

Ответ: 15.