СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 14769

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 0

WHILE S < S*S

    S = S - 1

    N = N + 2

WEND

PRINT N

s = 25

n = 0

while s < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while s < s*s do begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока s < s*s

        s := s - 1;

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 0;

    while (s < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n;

    return 0;

}

 

Решение.

Цикл будет выполняться для всех S=25, 24, 23, ..., 2, то есть 24 раз. Поэтому начальное значение n будет 24 раз увеличиваться на 2. Поэтому конечное значение n = 24 · 2 = 48.

 

Ответ: 48.