СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13619

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 2

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

 

Пояснение.

Цикл выполняется, пока s · s больше 91. При s = 9 этот цикл уже не выполнится. Так как изначально s = 20, а в цикле оно уменьшается на 1, то наш цикл выполнится 11 раз. Тогда итоговое значение n = 11 · 2 = 22.

 

Ответ:22.

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504