≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13565

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 165

  S = S + 15

  N = N * 2

WEND

PRINT N

s = 0

n = 1

while s < 165:

  s = s + 15

  n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 1;

  while s < 165 do

  begin

    s := s + 15;

    n := n * 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 1

  s := 0

  нц пока s < 165

    s = s + 15

    n = n * 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0;

  int n = 1;

  while (s < 165) {

    s = s + 15;

    n = n * 2;

  }

  cout << n << endl;

  return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 165, т. е. переменная s определяет, сколько раз выполнится цикл.

Цикл выполнится раз. На одиннадцатом шаге s станет равной 165, и условие s < 165 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 211 = 2048.

 

Ответ: 2048.

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104