СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13538

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 150

     S = S + 15

     N = N*2

WEND

PRINT N

s = 0

n = 1

while s < 150:

    s = s + 15

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 1;

while s < 150 do

begin

    s = s + 15;

    n = n * 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока s < 150

    s = s + 15

    n = n * 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 1;

    while (s < 150) { s = s + 15; n = n * 2; }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполнется 10 раз, т.к. после десятого раза s = 150 и не меньше чем 150. Значит, n = 1 будет умножаться на 2 десять раз то есть

 

Ответ: 1024 .

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103