≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13484

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S <= 10*S

     S = S + 1

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s <= 10*s:

    s = s + 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s <= 10*s do

begin

    s := s + 1;

    n := n + 3;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s <= 10*s

    s := s + 1

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (2*s*s <= 10*s) { s = s + 1; n = n + 3; }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие 2 · s · s <= 10 · s. Т.е. пока s <=5. Значит, цикл while выполнится 6 раз. Тогда значение n будет равно 6 * 3 = 18.

 

Ответ: 18.

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203