СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13404

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 99

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 99:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 99 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 99

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s*s < 99) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s · s < 99, т. е. переменная s определяет, сколько раз выполнится цикл. Можно заметить, что он выполнится 10 раз, т. к. при s = 10, s · s = 100. Следовательно, значение n будет равно 10 · 2 = 20.

 

Ответ: 20.

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303