СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13354

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 71

     S = S + 10

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 71:

    s = s + 10

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 71 do

begin

    s := s + 10;

    n := n + 3

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 71

    s := s + 10

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s < 71) { s = s + 10; n = n + 3; }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 71, т. е. переменная s определяет, сколько раз выполнится цикл. Заметим, что 8 · 10 > 71. Значит, после 8 входа в цикл s станет равной 80 и условие s < 71 окажется невыполненным. Следовательно, значение n будет равно 3 · 8 = 24.

 

Ответ: 24.

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике