≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 11237

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 5

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 5

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 5

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 5

  end;

  writeln(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 5;

  }

  cout << n << endl;

  return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 165, т. е. переменная s определяет, сколько раз выполнится цикл.

Цикл выполнится раз, здесь квадратные скобки означают взятие целой части числа. Заметим, что в переменной n накапливается число заходов в цикл, умноженное на 5. То есть n = 11 * 5 = 55.

 

Ответ: 55.