≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 10498

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 65

S = S + 6

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 65:

    s = s + 6

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s < 65 do

    begin

        s := s + 6;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

  цел n, s

  s := 0

  n := 0

  нц пока s < 65

    s := s + 6

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 0;

    while (s < 65)

    {

        s = s + 6;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Пояснение.

На каждой итерации цикла увеличивается на 6. Цикл выполняется, пока меньше 65. Значит, всего цикл сделает итераций. Каждую итерацию увеличивается на 2, то есть в конце .