СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 10409

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 2

print(n)

Пас­кальАл­го­рит­ми­че­ский язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 2;

  }

  cout « n « endl;

  return 0;

}

 

Ре­ше­ние.

Пусть цикл вы­пол­нит­ся x раз. Тогда после окон­ча­ния его ра­бо­ты . Прервётся цикл тогда, когда будет вы­пол­не­но не­ра­вен­ство или же . Найдём наи­мень­шее целое x, при ко­то­ром оно вы­пол­нит­ся.

На­хо­дим . Тогда .