≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 10382

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 3

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 3;

  }

  cout << n << endl;

  return 0;

}

 

Пояснение.

Пусть цикл выполнится x раз. Тогда после окончания его работы . Прервётся цикл тогда, когда будет выполнено неравенство или же . Найдём наименьшее целое x, при котором оно выполнится.

Находим . Тогда .