≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 10311

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 2;

  }

  cout << n << endl;

  return 0;

}

 

Пояснение.

Цикл прервётся тогда, когда будет выполнено неравенство . Найдём наименьшее целое s, при котором оно выполнится. Столько же раз выполнится цикл.

Наименьшее целое . Тогда .