СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Две функции

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 21 № 10297

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 21. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) <= K*G(I)

  I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N * N

END FUNCTION

 

FUNCTION G(N)

  G = N * N

END FUNCTION

def f(n):

  return n*n*n

 

def g(n):

  return n*n

 

k = int(input())

i = 1

while f(i) <= k*g(i):

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n * n;

end;

 

function g(n: longint): longint;

begin

  g := n*n;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) <= k*g(i) do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел i, k

  ввод k

  i := 1

  нц пока f(i) <= k*g(i)

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n * n

кон

 

алг цел g(цел n)

нач

  знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n * n;

}

 

long g(long n) {

  return n*n;

}

 

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) <= k*g(i))

    i++;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 10297: 10324 Все


2
Задание 21 № 10484

Напишите в ответе наибольшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 49. Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

    I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N * N

END FUNCTION

 

FUNCTION G(N)

  G = 2*N + 1

END FUNCTION

def f(n):

  return n*n*n

 

def g(n):

  return 2*n + 1

 

k = int(input())

i = 1

while f(i) < g(k):

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n * n;

end;

 

function g(n: longint): longint;

begin

  g := 2*n + 1;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) < g(k) do

    i := i + 1;

  writeln(i)

end.

алг

нач

  цел i, k

  ввод k

  i := 1

  нц пока f(i) < g(k)

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n * n

кон

 

алг цел g(цел n)

нач

  знач := 2*n + 1

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n * n;

}

 

long g(long n) {

  return 2*n + 1;

}

 

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) < g(k))

    i++;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 10484: 10511 Все


3
Задание 21 № 11250

Определите число, которое напечатает программа. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM I AS LONG

I = 1

WHILE F(I) < G(I)

  I = I * 2

WEND

PRINT I

FUNCTION F(N)

  F = N * N

END FUNCTION

FUNCTION G(N)

  G = 1000*N + 3

END FUNCTION

def f(n):

    return n*n

def g(n):

    return 1000*n+3

i = 1

while f(i) < g(i):

    i *= 2

print (i)

Алгоритмический языкПаскаль

алг

нач

  цел i

  i := 1

  нц пока f(i) < g(i)

    i := i * 2

  кц

  вывод i

кон

алг цел f(цел n)

нач

  знач := n * n

кон

алг цел g(цел n)

нач

  знач := 1000*n + 3

кон

var

  i : longint;

function f(n: longint): longint;

begin

  f := n * n;

end;

function g(n: longint): longint;

begin

  g := 1000*n + 3;

end;

begin

  i := 1;

  while f(i) < g(i) do

    i := i*2;

  writeln(i)

end.

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n;

}

long g(long n) {

  return 1000*n + 3;

}

int main()

{

  long i;

  i = 1;

  while (f(i) < g(i))

    i = i*2;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 11250: 11277 Все


4
Задание 21 № 11317

Напишите в ответе число, которое выведет программа в качестве ответа.

 

 

БейсикPython

DIM K, I AS LONG

I = 1

WHILE F(I) <= G(I)

    I = I*2

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N

END FUNCTION

 

FUNCTION G(N)

    G = N*2000 + 3

END FUNCTION

def f(n):

    return n*n

 

def g(n):

    return n*2000 + 3

 

i = 1

while f(i) <= g(i):

    i*=2

print(i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n;

end;

 

function g(n: longint): longint;

begin

    g := n*2000 + 3;

end;

 

begin

    i := 1;

    while f(i) <= g(i) do

        i := i*2;

    writeln(i)

end.

алг

нач

    цел i, k

    i := 1

    нц пока f(i) <= g(i)

        i := i*2

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n

кон

 

алг цел g(цел n)

нач

    знач := n*2000 + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n;

}

 

long g(long n) {

    return n*2000 + 3;

}

 

int main()

{

    long k, i;

    i = 1;

    while(f(i) <= g(i))

        i = i*2;

    cout << i << endl;

    return 0;

}

 

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.
Решение · · Видеокурс ·

5
Задание 21 № 13417

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 10. Для Вашего удобства программа приведена на пяти языках программирования

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(I)+K

    I = I + 1

WEND

  PRINT I

FUNCTION F(N)

  F = (N+1) * (N+1)

END FUNCTION

FUNCTION G(N)

    G = N * N

END FUNCTION

def f(n):

    return (n+1)*(n+1)

def g(n):

    return n*n

i = 1

k = int(input())

while f(i) < g(i) + k:

    i+=1

print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := (n+1) * (n+1);

end;

function g(n: longint) : longint;

begin

    g:= n * n;

end;

begin

    readln(k);

    i := 1;

     while f(i) < g(i) + k do

        i := i+1;

    writeln(i)

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < g(i) + k

        i := i + 1

    кц

    вывод i

    все

кон

алг цел f(цел n)

нач

    знач := (n+1) * (n+1)

кон

алг цел g(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return (n+1) * (n+1);

}

long g(long n) {

    return n * n ;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < g(i)+ k) {

        i++;

    }

        cout << i << endl;

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

Пройти тестирование по этим заданиям