СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Алгоритмы с использованием условного оператора

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задания Д16 № 3361

Дан фраг­мент про­грам­мы, об­ра­ба­ты­ва­ю­щий мас­сив А из 10 эле­мен­тов:

 

 

Бей­сик Python

j = 1

FOR i = 1 TO 10

    IF A(i) = A(j) THEN

        j = i

    ENDIF

NEXT i

s = j

j = 1

for i in range(1, 11):

    if A[i] == A[j]:

        j = i

s = j

Ал­го­рит­ми­че­ский язык Пас­каль

j := 1

нц для i от 1 до 10

    если A[i] = A[j] то

        j := i

    все

кц

s := j

j := 1;

for i := 1 to 10 do

    if A[i] = A[j] then j := i;

s := j;

Си++

j = 1;

for (i = 1; i <= 10; i++)

    if (A[i] == A[j])

    {

        j = i;

    }

s = j;

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния этого ал­го­рит­ма?

 

1) 1

2) 10

3) ин­дек­су эле­мен­та, рав­но­го пер­во­му, и име­ю­ще­му наи­боль­ший ин­декс

4) ин­дек­су эле­мен­та, рав­но­го по­след­не­му, и име­ю­ще­му наи­мень­ший ин­декс


2
Задания Д16 № 3363

Дан фраг­мент про­грам­мы, об­ра­ба­ты­ва­ю­щий двух­мер­ный мас­сив A раз­ме­ром nxn.

 

 

Бей­сикPython

FOR i = 1 TO n-1

    FOR j = i+1 TO n

        IF A[i,1] < A[j,1] THEN

            k=A(i,1)

            A(i,1)=A(j,1)

            A(j,1)=k

    NEXT j

NEXT i

for i in range(1, n):

    for j in range(i+1, n+1):

        if A[i,1] < A[j,1]:

            k=A[i,1]

            A[i,1]=A[j,1]

            A[j,1]=k

Пас­кальАл­го­рит­ми­че­ский язык

for i:= 1 to n-1 do

    for j:=i+1 to n do

        if A[i,1] < A[j,1] then begin

            k:=A[i,1];

            A[i,1]:=A[j,1];

            A[j,1]:=k;

        end;

нц для i от 1 до n-1

    нц для j от i+1 до n

        если A[i,1] < A[j,1] то

            k:=A[i,1]

            A[i,1]:=A[j,1]

            A[j,1]:=k

    кц

кц

Си++

for (i = 1; i <= n-1; i++) {

    for (j = i+1; j <= n; j++) {

        if (A[i][1] < A[j][1]){

            k=A[i][1];

            A[i][1]=A[j][1];

            A[j][1]=k;

        }

    }

}

 

 

В этом фраг­мен­те:

 

1) упо­ря­до­чи­ва­ет­ся пер­вая стро­ка мас­си­ва по убы­ва­нию

2) упо­ря­до­чи­ва­ет­ся пер­вый стол­бец мас­си­ва по убы­ва­нию

3) за­ме­ня­ют­ся эле­мен­ты k-ого столб­ца таб­ли­цы

4) за­ме­ня­ют­ся эле­мен­ты k-ой стро­ки таб­ли­цы


3
Задания Д16 № 3380

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 1 до 10. Ниже пред­став­лен фраг­мент этой про­грам­мы, в ко­то­ром зна­че­ния эле­мен­тов мас­си­ва сна­ча­ла за­да­ют­ся, а затем ме­ня­ют­ся.

 

 

Бей­сикPython

 

FOR i = 1 TO 10

    A(i) = 5*i

NEXT i

FOR i = 1 TO 10

    k = A(i) - 2

    A(10-i+1) = k

NEXT i

 

 

for i in range(1, 11):

    A[i] = 5*i

for i in range(1, 11):

    k = A[i]-2

    A[10-i+1]=k

Пас­кальАл­го­рит­ми­че­ский язык

 

for i : = 1 to 10

    do A[i] : = 5*i;

for i : = 1 to 10 do begin

    k:=A[i]-2;

    A[10-i+1]:=k;

end;

 

нц для i от 1 до 10

    A[i] : = 5*i

кц

нц для i от 1 до 10

    k:=A[i]-2

    A[10-i+1]:=k

кц

 

Си++

 

for (i = 1; i <= 10; i++) {

    A[i] = 5*i;

}

for (i = 1; i <= 10; i++) {

    k=A[i]-2;

    A[10-i+1]=k;

}

 

 

 

Чему будут равны эле­мен­ты этого мас­си­ва?

 

1) 1 6 11 16 21 23 18 13 8 3

2) 3 8 13 18 23 28 33 38 43 48

3) 48 43 38 33 28 23 18 13 8 3

4) 1 6 11 16 21 26 31 36 41 46


4
Задания Д16 № 3806

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до n. Ниже пред­став­лен фраг­мент одной и той же про­грам­мы, за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния, об­ра­ба­ты­ва­ю­щей дан­ный мас­сив:

 

 

Бей­сикПас­каль

s = 0

z = A(n)

FOR i = 0 TO n

    IF A(i) > z THEN s = s + 1

NEXT i

s: = 0;

z: = A[n];

for i: = 0 to n do

    begin

        if A[i] > z then

            s: = s + 1;

    end

Си++Ал­го­рит­ми­че­ский язык
s = 0;

z = A[n];

for (i = 0; i <= n; i++){

    if (A[i] > z)

        s++;

}

s: = 0

z: = A[n]

нц для i от 0 до n

если A[i] > z то

    s: = s + 1

все

кц

Python

s = 0

z = A[n]

for i in range(0, n+1):

    if A[i] > z:

        s = s + 1;

 

 

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной про­грам­мы, при любых зна­че­ни­ях эле­мен­тов мас­си­ва?

 

1) Ми­ни­маль­но­му эле­мен­ту в мас­си­ве A

2) Ко­ли­че­ству эле­мен­тов мас­си­ва A, боль­ших по­след­не­го эле­мен­та мас­си­ва

3) Ин­дек­су по­след­не­го эле­мен­та мас­си­ва А, ко­то­рый мень­ше A[0]

4) Ко­ли­че­ству эле­мен­тов мас­си­ва A, мень­ших по­след­не­го эле­мен­та мас­си­ва


Аналоги к заданию № 3806: 4583 Все

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.

5
Задания Д16 № 5997

Ниже при­ведён фраг­мент про­грам­мы, за­пи­сан­ный на четырёх язы­ках про­грам­ми­ро­ва­ния.

Мас­сив A од­но­мер­ный; в про­грам­ме рас­смат­ри­ва­ет­ся его фраг­мент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

 

Бей­сикПас­каль

J = 1

FOR I = 1 TO n

    IF A(I) < A(J) THEN J =I NEXT I

s = J

j :=1;

for i: = 1 to n do

    begin

        if A[i] < A[j] then

            j := i

    end;

s := j;

Си++Ал­го­рит­ми­че­ский язык

j = 1;

for (i = 1; i <= n; i++) {

    if (A[i] < A[j]) {

        j = i;

    }

}

s = j;

j := 1

нц для i от 1 до n

    если A[i] < A[j] то

        j := i

    все

кц

s := j

Python

j = 1

for i in range(1, n+1):

    if A[i] < A[j]:

        j = i

s = j

 

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­но­го фраг­мен­та про­грам­мы?

 

1) ми­ни­маль­но­му эле­мен­ту в мас­си­ве A

2) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве A (наи­мень­ше­му из таких ин­дек­сов, если ми­ни­маль­ных эле­мен­тов не­сколь­ко)

3) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве A (наи­боль­ше­му из таких ин­дек­сов, если ми­ни­маль­ных эле­мен­тов не­сколь­ко)

4) ко­ли­че­ству эле­мен­тов, рав­ных ми­ни­маль­но­му в мас­си­ве A

Источник: Демонстрационная версия ЕГЭ—2014 по информатике.

6
Задания Д16 № 5355

Ниже при­ведён фраг­мент про­грам­мы, за­пи­сан­ный на четырёх язы­ках про­грам­ми­ро­ва­ния.

 

Мас­сив А од­но­мер­ный; в про­грам­ме рас­смат­ри­ва­ет­ся его фраг­мент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

Бей­сик

Пас­каль

J = 1

FOR I = 1 to n

    IF A(I) < A(J) THEN J = I

NEXT I

s = J

j := 1;

for i := 1 to n do

    begin

        if A[i] < A[j] then

            j := i

    end;

s := j;

Си++

Ал­го­рит­ми­че­ский язык

j = 1;

for (i = 1; i <= n; i++) {

    if (A[i] < A[j]){

        j = i;

    }

}

s = j;

j := 1

нц для i от 1 до n

если A[i] < A[j] то

    j := i

все

кц

s := j

Python

j = 1

for i in range(1, n+1):

    if A[i] < A[j]:

        j = i

s = j

 

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­но­го фраг­мен­та про­грам­мы?

 

1) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве А (наи­мень­ше­му из таких ин­дек­сов, если ми­ни­маль­ных эле­мен­тов не­сколь­ко)

2) ми­ни­маль­но­му эле­мен­ту в мас­си­ве А

3) ко­ли­че­ству эле­мен­тов, рав­ных ми­ни­маль­но­му в мас­си­ве А

4) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве А (наи­боль­ше­му из таких ин­дек­сов, если ми­ни­маль­ных эле­мен­тов не­сколь­ко)

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 1.

7
Задания Д16 № 6570

Ниже при­ведён фраг­мент про­грам­мы, за­пи­сан­ный на четырёх язы­ках про­грам­ми­ро­ва­ния. Мас­сив A од­но­мер­ный; в про­грам­ме рас­смат­ри­ва­ет­ся его фраг­мент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

Бей­сикПас­каль

s = 0

FOR i = 1 TO n

    IF A(i)<0 THEN s = s – A(i)

NEXT i

s := 0;

for i := 1 to n do

    begin

        if A[i]<0 then

            s := s – A[i]

    end;

Си++Ал­го­рит­ми­че­ский язык

s = 0;

for (i = 1; i <= n; i++) {

    if (A[i] < 0) {

        s = s - A[i];

    }

}

s := 0

нц для i от 1 до n

    если A[i]<0 то

        s := s – A[i]

все

кц

Python

s = 0

for i in range(1, n+1):

    if A[i]<0:

        s = s - A[i]

 

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­но­го фраг­мен­та про­грам­мы?

 

1) мо­ду­лю суммы всех от­ри­ца­тель­ных эле­мен­тов мас­си­ва A

2) ко­ли­че­ству от­ри­ца­тель­ных эле­мен­тов в мас­си­ве A

3) сумме всех от­ри­ца­тель­ных эле­мен­тов мас­си­ва A

4) сред­не­му ариф­ме­ти­че­ско­му всех от­ри­ца­тель­ных эле­мен­тов в мас­си­ве A

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 802.

Пройти тестирование по этим заданиям