СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Рекурсивные функции с текстовым выводом

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 11 № 7459

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

БейсикPython

SUB F(n)

    PRINT n

    IF n < 5 THEN

        F(n + 1)

        F(n + 3)

    END IF

END SUB

def F(n):

    print(n)

    if n < 5:

        F(n + 1)

        F(n + 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

    begin

        writeln(n);

        if n < 5 then

            begin

                F(n + 1);

                F(n + 3)

            end

    end

алг F(цел n)

нач

вывод n, нс

если n < 5 то

    F(n + 1)

    F(n + 3)

все

кон

С++

void F(int n)

{

    cout << n << endl;

    if (n < 5) {

        F(n + 1);

        F(n + 3);

    }

}

 

Чему равна сумма всех чисел, напечатанных на экране при выполнении вызова F(1)?

Источник: Де­мон­стра­ци­он­ная версия ЕГЭ—2015 по информатике.

2
Задание 11 № 7756

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

БейсикPython

SUB F(n)

    PRINT n

    IF n > 0 THEN

        F(n - 1)

        F(n - 3)

     END IF

END SUB

def F(n):

    print(n)

    if n > 0:

        F(n - 1)

        F(n - 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

    begin

        writeln(n);

        if n > 0 then

            begin

                F(n - 1);

                F(n - 3)

            end

end

алг F(цел n)

нач

вывод n, нс

если n > 0 то

    F(n - 1)

    F(n - 3)

все

кон

Си

void F(int n)

{

    cout << n;

    if (n > 0)

    {

        F(n - 1);

        F(n - 3);

    }

}

 

Чему равна сумма всех чисел, напечатанных на экране при выполнении вызова F(5)?


3
Задание 11 № 7783

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

БейсикPython

SUB F(n)

    PRINT n

    IF n > 1 THEN

        F(n - 1)

        F(n - 3)

    END IF

END SUB

def F(n):

    print(n)

    if n > 1:

        F(n - 1)

        F(n - 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

    begin

        writeln(n);

        if n > 1 then

            begin

                F(n - 1);

                F(n - 3)

            end

    end

алг F(цел n)

нач

вывод n, нс

если n > 1 то

    F(n - 1)

    F(n - 3)

все

кон

C++

void F(int n)

{

    cout << n;

    if (n > 1)

    {

        F(n - 1);

        F(n - 3);

    }

}

 

Чему равна сумма всех чисел, напечатанных на экране при выполнении вызова F(6)?


4
Задание 11 № 8659

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

 

БейсикPython

SUB F(n)

    PRINT n

    IF n < 5 THEN

        F(n + 1)

        F(n + 2)

    END IF

END SUB

def F(n):

    print(n)

    if n < 5:

        F(n + 1)

        F(n + 2)

Алгоритмический языкПаскаль

алг F(цел n)

нач

    вывод n, нс

    если n < 5 то

        F(n + 1)

        F(n + 2)

    все

кон

procedure F(n: integer);

begin

    writeln(n);

    if n < 5 then

    begin

        F(n + 1);

        F(n + 2)

    end

end

Си

void F(int n)

{

    cout << n;

    if (n < 5)

    {

        F(n + 1);

        F(n + 2);

    }

}

 

 

Чему равна сумма всех чисел, напечатанных на экране при выполнении вызова F(2)?


5
Задание 11 № 9163

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

 

БейсикPython

SUB F(n)

    PRINT n

    IF n < 4 THEN

        F(n + 1)

        F(n + 3)

    END IF

END SUB

def F(n):

    print(n)

    if n < 4:

        F(n + 1)

        F(n + 3)

Алгоритмический языкПаскаль

алг F(цел n)

нач

    вывод n, нс

    если n < 4 то

        F(n + 1)

        F(n + 3)

    все

кон

procedure F(n: integer);

begin

    writeln(n);

    if n < 4 then

    begin

        F(n + 1);

        F(n + 3)

    end

end

Си

void F(int n)

{

    cout << n;

    if (n < 4)

    {

        F(n + 1);

        F(n + 3);

    }

}

 

 

Чему равна сумма всех чисел, напечатанных на экране при выполнении вызова F(1)?


Пройти тестирование по этим заданиям