СДАМ ГИА






Каталог заданий. Вызов рекурсивных процедур
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 11 № 7459

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

SUB F(n)

    PRINT n

    IF n < 5 THEN

        F(n + 1)

        F(n + 3)

    END IF

END SUB

def F(n):

    print(n)

    if n < 5:

        F(n + 1)

        F(n + 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

    begin

        writeln(n);

        if n < 5 then

            begin

                F(n + 1);

                F(n + 3)

            end

    end

алг F(цел n)

нач

вывод n, нс

если n < 5 то

    F(n + 1)

    F(n + 3)

все

кон

Си

void F(int n)

{

    printf("%d\n", n);

    if (n < 5) {

        F(n + 1);

        F(n + 3);

    }

}

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(1)?

Источник: Де­мон­стра­ци­он­ная версия ЕГЭ—2015 по информатике.

2
Задание 11 № 7668

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

SUB F(n)

    IF n > 2 THEN

        F = F(n - 1) +F(n-2)

    ELSE

        F = 1

    END IF

END SUB

def F(n):

    if n > 2:

        return F(n-1)+ F(n-2)

    else: return 1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n - 1) + F(n - 2)

    else

        F := 1;

end;

алг цел F(цел n)

нач

если n > 2

то

    знач := F(n - 1)+F(n - 2)

иначе

    знач := 1

все

кон

Си

int F(int n)

{

    if (n > 2)

        return F(n-1) + F(n-2);

    else return 1;

}

 

Чему будет равно значение, вы­чис­лен­ное ал­го­рит­мом при вы­пол­не­нии вы­зо­ва F(5)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 26.11.2014 ва­ри­ант ИН10301.

3
Задание 11 № 7695

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

SUB F(n)

    IF n > 2 THEN

        F = F(n - 1) +F(n-2)

    ELSE

        F = 1

    END IF

END SUB

def F(n):

    if n > 2:

        return F(n-1)+ F(n-2)

    else: return 1

ПаскальАлгоритмический язык

procedure F(n: integer): integer;

    begin

    if n > 2 then

        F := F(n - 1) + F(n - 2)

    else

        F := 1;

    end;

алг цел F(цел n)

нач

если n > 2

то

    знач := F(n - 1)+F(n - 2)

иначе

    знач := 1

все

кон

Си

int F(int n)

{

    if (n > 2)

        return F(n-1) + F(n-2);

    else return 1;

}

 

Чему будет равно значение, вы­чис­лен­ное ал­го­рит­мом при вы­пол­не­нии вы­зо­ва F(6)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 26.11.2014 ва­ри­ант ИН10302.

4
Задание 11 № 7756

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

SUB F(n)

    PRINT n

    IF n > 0 THEN

        F(n - 1)

        F(n - 3)

     END IF

END SUB

def F(n):

    print(n)

    if n > 0:

        F(n - 1)

        F(n - 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

    begin

        writeln(n);

        if n > 0 then

            begin

                F(n - 1);

                F(n - 3)

            end

end

алг F(цел n)

нач

вывод n, нс

если n > 0 то

    F(n - 1)

    F(n - 3)

все

кон

Си

void F(int n)

{

    printf("%d\n", n);

    if (n > 0)

    {

        F(n - 1);

        F(n - 3);

    }

}

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(5)?

Источник: СтатГрад: Диагностическая работа по ин­фор­ма­ти­ке 26.01.2015 ва­ри­ант ИН10501.

5
Задание 11 № 7783

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

SUB F(n)

    PRINT n

    IF n > 1 THEN

        F(n - 1)

        F(n - 3)

    END IF

END SUB

def F(n):

    print(n)

    if n > 1:

        F(n - 1)

        F(n - 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

    begin

        writeln(n);

        if n > 1 then

            begin

                F(n - 1);

                F(n - 3)

            end

    end

алг F(цел n)

нач

вывод n, нс

если n > 1 то

    F(n - 1)

    F(n - 3)

все

кон

Си

void F(int n)

{

    printf("%d\n", n);

    if (n > 1)

    {

        F(n - 1);

        F(n - 3);

    }

}

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(6)?

Источник: СтатГрад: Диагностическая ра­бо­та по ин­фор­ма­ти­ке 26.01.2015 ва­ри­ант ИН10502.

6
Задание 11 № 7922

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n - 1) + F(n-2)

    ELSE

        F = n

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1)+ F(n-2)

    else: return n

ПаскальАлгоритмический язык

function F(n: integer): integer;

     begin

        if n > 2 then

            F := F(n - 1) + F(n - 2)

        else

            F := n;

    end;

алг цел F(цел n)

нач

если n > 2

то

    знач := F(n - 1)+F(n - 2)

иначе

    знач := n

все

кон

Си

int F(int n)

{

    if (n > 2)

        return F(n-1) + F(n-2);

    else return n;

}

 

Чему будет равно значение, вы­чис­лен­ное ал­го­рит­мом при вы­пол­не­нии вы­зо­ва F(5)?

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 27.02.2015 ва­ри­ант ИН10901.

7
Задание 11 № 7987

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n - 1) + F(n-2)

    ELSE

        F = n

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1)+ F(n-2)

    else: return n

ПаскальАлгоритмический язык

function F(n: integer): integer;

     begin

        if n > 2 then

            F := F(n - 1) + F(n - 2)

        else

            F := n;

    end;

алг цел F(цел n)

нач

если n > 2

то

    знач := F(n - 1)+F(n - 2)

иначе

    знач := n

все

кон

Си

int F(int n)

{

    if (n > 2)

        return F(n-1) + F(n-2);

    else return n;

}

 

Чему будет равно значение, вы­чис­лен­ное ал­го­рит­мом при вы­пол­не­нии вы­зо­ва F(6)?

Источник: СтатГрад: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 27.02.2015 ва­ри­ант ИН10902.

8
Задание 11 № 8099

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функ­ции (процедуры): F и G.

 

БейсикPython

DECLARE SUB F(n)

DECLARE SUB G(n)

 

SUB F(n)

    IF n > 0 THEN G(n - 1)

END SUB

 

SUB G(n)

    PRINT "*"

    IF n > 1 THEN F(n - 2)

END SUB

def F(n):

    if n > 0:

        G(n - 1)

 

def G(n):

    print("*")

    if n > 1:

        F(n - 2)

ПаскальАлгоритмический язык

procedure F(n: integer); forward;

procedure G(n: integer); forward;

 

procedure F(n: integer);

begin

    if n > 0 then

        G(n - 1);

end;

 

procedure G(n: integer);

begin

    writeln('*');

    if n > 1 then

        F(n - 2);

end;

алг F(цел n)

нач

    если n > 0 то

        G(n - 1)

    все

кон

алг G(цел n)

нач

    вывод "*"

    если n > 1 то

        F(n - 2)

    все

кон

Си

void F(int n);

void G(int n);

 

void F(int n){

    if (n > 0)

         G(n - 1);

}

 

void G(int n){

    printf("*");

    if (n > 1)

         F(n - 2);

}

 

Сколько сим­во­лов «звёздочка» будет на­пе­ча­та­но на экра­не при вы­пол­не­нии вы­зо­ва F(11)?

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

9
Задание 11 № 8659

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

 

БейсикPython

SUB F(n)

    PRINT n

    IF n < 5 THEN

        F(n + 1)

        F(n + 2)

    END IF

END SUB

def F(n):

    print(n)

    if n < 5:

        F(n + 1)

        F(n + 2)

Алгоритмический языкПаскаль

алг F(цел n)

нач

    вывод n, нс

    если n < 5 то

        F(n + 1)

        F(n + 2)

    все

кон

procedure F(n: integer);

begin

    writeln(n);

    if n < 5 then

    begin

        F(n + 1);

        F(n + 2)

    end

end

Си

void F(int n)

{

    printf("%d\n", n);

    if (n < 5)

    {

        F(n + 1);

        F(n + 2);

    }

}

 

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(2)?

Источник: СтатГрад: Ре­пе­ти­ци­он­ная ра­бо­та по ин­фор­ма­ти­ке 01.04.2015 ИН10701

10
Задание 11 № 9163

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

 

БейсикPython

SUB F(n)

    PRINT n

    IF n < 4 THEN

        F(n + 1)

        F(n + 3)

    END IF

END SUB

def F(n):

    print(n)

    if n < 4:

        F(n + 1)

        F(n + 3)

Алгоритмический языкПаскаль

алг F(цел n)

нач

    вывод n, нс

    если n < 4 то

        F(n + 1)

        F(n + 3)

    все

кон

procedure F(n: integer);

begin

    writeln(n);

    if n < 4 then

    begin

        F(n + 1);

        F(n + 3)

    end

end

Си

void F(int n)

{

    printf("%d\n", n);

    if (n < 4)

    {

        F(n + 1);

        F(n + 3);

    }

}

 

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(1)?

Источник: СтатГрад: Ре­пе­ти­ци­он­ная работа по информатике 01.04.2015 ИН10702

11
Задание 11 № 9195

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n-1)+F(n-2)+F(n-3)

    ELSE

        F = n

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1)+F(n-2)+F(n-3)

    else:

        return n

Алгоритмический языкПаскаль

алг цел F(цел n)

нач

    если n > 2

    то

        знач:=F(n-1)+F(n-2)+F(n-3)

    иначе

        знач := n

    все

кон

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n-1)+F(n-2)+F(n-3)

    else

        F := n;

end;

Си

int F(int n)

{

    if (n > 2)

        return F(n-1)+F(n-2)+F(n-3);

    else return n;

}

 

 

Чему будет равно значение, вы­чис­лен­ное ал­го­рит­мом при вы­пол­не­нии вы­зо­ва F(5)?

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 06.05.2015 ИН10801

12
Задание 11 № 9303

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n-1)+F(n-2)+F(n-3)

    ELSE

        F = n

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1)+F(n-2)+F(n-3)

    else:

        return n

Алгоритмический языкПаскаль

алг цел F(цел n)

нач

    если n > 2

    то

        знач:=F(n-1)+F(n-2)+F(n-3)

    иначе

        знач := n

    все

кон

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n-1)+F(n-2)+F(n-3)

    else

        F := n;

end;

Си

int F(int n)

{

    if (n > 2)

        return F(n-1)+F(n-2)+F(n-3);

    else return n;

}

 

 

Чему будет равно значение, вы­чис­лен­ное ал­го­рит­мом при вы­пол­не­нии вы­зо­ва F(6)?

Источник: СтатГрад: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 06.05.2015 ИН10802

13
Задание 11 № 9362

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функ­ции (процедуры): F и G.

 

БейсикPython

DECLARE SUB F(n)

DECLARE SUB G(n)

 

SUB F(n)

    IF n > 0 THEN G(n - 1)

END SUB

 

SUB G(n)

    PRINT "*"

    IF n > 1 THEN F(n - 3)

END SUB

def F(n):

    if n > 0:

        G(n - 1)

def G(n):

    print("*")

    if n > 1:

        F(n - 3)

ПаскальАлгоритмический язык

procedure F(n: integer); forward;

procedure G(n: integer); forward;

 

procedure F(n: integer);

begin

    if n > 0 then

        G(n - 1);

end;

 

procedure G(n: integer);

begin

    writeln('*');

    if n > 1 then

        F(n - 3);

end;

алг F(цел n)

нач

    если n > 0 то

        G(n - 1)

    все

кон

 

алг G(цел n)

нач

    вывод "*"

    если n > 1 то

        F(n - 3)

    все

кон

Си

void F(int n);

void G(int n);

 

void F(int n){

    if (n > 0)

        G(n - 1);

}

 

void G(int n){

    printf("*");

    if (n > 1)

        F(n - 3);

}

 

 

Сколько сим­во­лов «звёздочка» будет на­пе­ча­та­но на экра­не при вы­пол­не­нии вы­зо­ва F(11)?

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

14
Задание 11 № 9646

Ниже на четырёх язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикПаскаль

SUB F(n)

  IF n > 0 THEN

    F(n - 4)

    PRINT n

    F(n \ 3)

  END IF

END SUB

procedure F(n: integer);

begin

  if n > 0 then

  begin

    F(n - 4);

    writeln(n);

    F(n div 3)

  end

end;

СиАлгоритмический язык

void F(int n)

{

if (n > 0)

  {

    F(n - 4);

    printf("%d\n", n);

    F(n / 3);

  }

}

алг F(цел n)

нач

  если n > 0 то

F(n - 4)

вывод n, нс

F(div(n, 3))

  все

кон 

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(9)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.09.2015 ИН10103

15
Задание 11 № 9692

Ниже на четырёх язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикПаскаль

SUB F(n)

  IF n > 0 THEN

    F(n - 4)

    F(n \ 3)

    PRINT n

  END IF

END SUB

procedure F(n: integer);

begin

  if n > 0 then

  begin

    F(n - 4);

    F(n div 3);

    writeln(n)

  end

end;

СиАлгоритмический язык

void F(int n)

{

if (n > 0)

  {

    F(n - 4);

    F(n / 3);

    printf("%d\n", n);

  }

}

алг F(цел n)

нач

  если n > 0 то

    F(n - 4)

    F(div(n, 3))

    вывод n, нс

  все

кон

 

Чему равна сумма всех чисел, на­пе­ча­тан­ных на экра­не при вы­пол­не­нии вы­зо­ва F(10)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.09.2015 ИН10104

16
Задание 11 № 9761

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функции: F и G.

 

БейсикPython

DECLARE FUNCTION F(n)

DECLARE FUNCTION G(n)

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n - 1) + G(n-2)

  ELSE

    F = 1

  END IF

END FUNCTION

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n - 1) + F(n-2)

  ELSE

    G = 1

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1)+ G(n-2)

  else: return 1

def G(n):

  if n > 2:

  return G(n-1) + F(n-2)

  else: return 1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n - 1) + G(n - 2)

  else

    F := 1;

end;

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n - 1) + F(n - 2)

  else

    G := 1;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n - 1) + G(n - 2)

    иначе

      знач := 1

  все

кон

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n - 1) + F(n - 2)

    иначе

      знач := 1

  все

кон

Си

int F(int n)

{

  if (n > 2)

    return F(n-1) + G(n-2);

  else return 1;

}

int G(int n)

{

  if (n > 2)

    return G(n-1) + F(n-2);

  else return 1;

}

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва F(7)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 02.12.2015 ИН10203

17
Задание 11 № 9797

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функции: F и G.

 

БейсикPython

DECLARE FUNCTION F(n)

DECLARE FUNCTION G(n)

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n - 1) + G(n-2)

  ELSE

    F = 1

  END IF

END FUNCTION

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n - 1) + F(n-2)

  ELSE

    G = 1

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1)+ G(n-2)

  else: return 1

def G(n):

  if n > 2:

  return G(n-1) + F(n-2)

  else: return 1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n - 1) + G(n - 2)

  else

    F := 1;

end;

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n - 1) + F(n - 2)

  else

    G := 1;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n - 1) + G(n - 2)

    иначе

      знач := 1

  все

кон

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n - 1) + F(n - 2)

    иначе

      знач := 1

  все

кон

Си

int F(int n)

{

  if (n > 2)

    return F(n-1) + G(n-2);

  else return 1;

}

int G(int n)

{

  if (n > 2)

    return G(n-1) + F(n-2);

  else return 1;

}

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва F(8)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 02.12.2015 ИН10204

18
Задание 11 № 10287

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функции: F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n - 1) + G(n - 2)

  ELSE

    F = n

  END IF

END FUNCTION

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n - 1) + F(n - 2)

  ELSE

    G = n + 1

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1) + G(n-2)

  else: return n

def G(n):

  if n > 2:

    return G(n-1) + F(n-2)

  else: return n+1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n - 1) + G(n - 2)

  else

    F := n;

end;

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n - 1) + F(n - 2)

  else

    G := n+1;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n - 1)+G(n - 2)

    иначе

      знач := n

  все

кон

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n - 1)+F(n - 2)

    иначе

      знач := n+1

  все

кон

Си

int F(int n)

{

  if (n > 2)

    return F(n-1) + G(n-2);

  else return n;

}

int G(int n)

{

  if (n > 2)

    return G(n-1) + F(n-2);

  else return n + 1;

}

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва F(6)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10303

19
Задание 11 № 10314

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функции: F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n - 1) + G(n - 2)

  ELSE

    F = n

  END IF

END FUNCTION

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n - 1) + F(n - 2)

  ELSE

    G = n + 1

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1) + G(n-2)

  else: return n

def G(n):

  if n > 2:

    return G(n-1) + F(n-2)

  else: return n+1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n - 1) + G(n - 2)

  else

    F := n;

end;

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n - 1) + F(n - 2)

  else

    G := n+1;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n - 1)+G(n - 2)

    иначе

      знач := n

  все

кон

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n - 1)+F(n - 2)

    иначе

      знач := n+1

  все

кон

Си

int F(int n)

{

  if (n > 2)

    return F(n-1) + G(n-2);

  else return n;

}

int G(int n)

{

  if (n > 2)

    return G(n-1) + F(n-2);

  else return n + 1;

}

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва G(6)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10304

20
Задание 11 № 10385

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функции: F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n-1)+G(n-1)+F(n-2)

  ELSE

    F = n

  END IF

END FUNCTION

 

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n-1)+F(n-1)+G(n-2)

  ELSE

    G = n+1

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1)+G(n-1)+F(n-2)

  else: return n

 

def G(n):

  if n > 2:

    return G(n-1)+F(n-1)+G(n-2)

  else: return n+1

ПаскальАлгоритмический язык

function F(n: integer):

integer;

begin

  if n > 2 then

    F := F(n-1)+G(n-1)+F(n-2)

  else

    F := n;

end;

 

function G(n: integer):

integer;

begin

  if n > 2 then

    G := G(n-1)+F(n-1)+G(n-2)

  else

    G := n+1;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n-1)+G(n-1)+F(n-2)

    иначе

      знач := n

  все

кон

 

алг цел G(цел n)

нач

  если n > 2

  то

    знач := G(n-1)+F(n-1)+G(n-2)

  иначе

    знач := n+1

  все

кон

Си

int F(int n) {

  if (n > 2)

    return F(n-1)+G(n-1)+F(n-2);

  else return n;

}

 

int G(int n){

  if (n > 2)

    return G(n-1)+F(n-1)+G(n-2);

  else return n+1;

}

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва G(5)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 18.03.2016 ИН10403

21
Задание 11 № 10412

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны две ре­кур­сив­ные функции: F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n-1)+G(n-1)+F(n-2)

  ELSE

    F = n

  END IF

END FUNCTION

 

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n-1)+F(n-1)+G(n-2)

  ELSE

    G = n+1

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1)+G(n-1)+F(n-2)

  else: return n

 

def G(n):

  if n > 2:

    return G(n-1)+F(n-1)+G(n-2)

  else: return n+1

ПаскальАлгоритмический язык

function F(n: integer):

integer;

begin

  if n > 2 then

    F := F(n-1)+G(n-1)+F(n-2)

  else

    F := n;

end;

 

function G(n: integer):

integer;

begin

  if n > 2 then

    G := G(n-1)+F(n-1)+G(n-2)

  else

    G := n+1;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n-1)+G(n-1)+F(n-2)

    иначе

      знач := n

  все

кон

 

алг цел G(цел n)

нач

  если n > 2

  то

    знач := G(n-1)+F(n-1)+G(n-2)

  иначе

    знач := n+1

  все

кон

Си

int F(int n) {

  if (n > 2)

    return F(n-1)+G(n-1)+F(n-2);

  else return n;

}

 

int G(int n){

  if (n > 2)

    return G(n-1)+F(n-1)+G(n-2);

  else return n+1;

}

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва F(5)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 18.03.2016 ИН10404

22
Задание 11 № 10474

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­на ре­кур­сив­ная функ­ция (процедура) F.

 

 

БейсикPython

SUB F(n)

    PRINT n,

    IF n > 2 THEN

       F(n − 3)

       F(n − 2)

       F(n − 1)

    END IF

END SUB

def F(n):

    print (n, end='')

    if n > 2:

        F(n − 3)

        F(n − 2)

        F(n − 1)

ПаскальАлгоритмический язык

procedure F(n: integer);

begin

    write(n);

    if n > 2 then

    begin

      F(n − 3);

      F(n − 2);

      F(n − 1)

    end

end;

алг F(цел n)

нач

    вывод n

    если n > 2 то

      F(n − 3)

      F(n − 2)

      F(n − 1)

    все

кон

Си

void F(int n ){

    printf("%d", n);

    if (n > 2) {

        F(n - 3);

        F(n - 2);

        F(n - 1);

    }

}

 

 

Что вы­ве­дет про­грам­ма при вы­зо­ве F(4)? В от­ве­те за­пи­ши­те по­сле­до­ва­тель­ность вы­ве­ден­ных цифр слит­но (без пробелов).

Источник: Типовые те­сто­вые за­да­ния по ин­фор­ма­ти­ке под ре­дак­ци­ей С. С. Крылова, Т. Е. Чуркиной. 2016. В. 1.

23
Задание 11 № 10501

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­на ре­кур­сив­ная функ­ция (процедура) F.

 

 

БейсикPython

SUB F(n)

    PRINT n,

    IF n > 2 THEN

       F(n − 1)

       F(n − 2)

       F(n − 3)

    END IF

END SUB

def F(n):

    print (n, end='')

    if n > 2:

        F(n − 1)

        F(n − 2)

        F(n − 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

begin

    write(n);

    if n > 2 then

    begin

      F(n − 1);

      F(n − 2);

      F(n − 3)

    end

end;

алг F(цел n)

нач

    вывод n

    если n > 2 то

      F(n − 1)

      F(n − 2)

      F(n − 3)

    все

кон

Си

void F(int n ){

    printf("%d", n);

    if (n > 2) {

        F(n − 1);

        F(n − 2);

        F(n − 3);

    }

}

 

 

Что вы­ве­дет про­грам­ма при вы­зо­ве F(4)? В от­ве­те за­пи­ши­те по­сле­до­ва­тель­ность вы­ве­ден­ных цифр слит­но (без пробелов).

Источник: Ти­по­вые те­сто­вые за­да­ния по ин­фор­ма­ти­ке под ре­дак­ци­ей С. С. Крылова, Т. Е. Чуркиной. 2016. В. 2.

24
Задание 11 № 11112

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ре­кур­сив­ный ал­го­ритм F.

 

БейсикPython

SUB F(n)

  IF n > 0 THEN

    PRINT "*"

    F(n - 1)

    F(n \ 3)

  END IF

END SUB

def F(n):

    if n > 0:

        print("*")

        F(n - 1)

        F(n // 3)

Алгоритмический языкПаскаль

алг F(цел n)

нач

  если n > 0 то

    вывод "*"

    F(n - 1)

    F(div(n, 3))

  все

кон

procedure F(n: integer);

begin

  if n > 0 then

  begin

    writeln('*');

    F(n - 1);

    F(n div 3)

  end

end

Си

void F(int n)

{

  if (n > 0)

  {

    printf("*");

    F(n - 1);

    F(n / 3);

  }

}

 

 

Сколько сим­во­лов «звёздочка» будет на­пе­ча­та­но на экра­не при вы­пол­не­нии вы­зо­ва F(6)?

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна
Пояснение · ·

25
Задание 11 № 11240

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны ре­кур­сив­ные функ­ции F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n-1)+G(n-1)+F(n-2)

  ELSE

    F = n

  END IF

END FUNCTION

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n-1)+F(n-1)+G(n-2)

  ELSE

    G = 3-n

  END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1)+G(n-1)+F(n-2)

    else: return n

def G(n):

    if n > 2:

        return G(n-1)+F(n-1)+G(n-2)

    else: return 3-n

Алгоритмический языкПаскаль

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n-1)+G(n-1)+F(n-2)

    иначе

      знач := n

    все

кон

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n-1)+F(n-1)+G(n-2)

    иначе

      знач := 3-n

  все

кон

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n-1)+G(n-1)+F(n-2)

  else

    F := n;

end;

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n-1)+F(n-1)+G(n-2)

  else

    G := 3-n;

end;

Си

int F(int n){

if (n > 2)

return F(n-1)+G(n-1)+F(n-2);

else return n;

}

int G(int n){

if (n > 2)

return G(n-1)+F(n-1)+G(n-2);

else return 3-n;

}

 

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва G(5)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 21.05.2016 ИН10503.

26
Задание 11 № 11267

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­са­ны ре­кур­сив­ные функ­ции F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n-1)+G(n-1)+F(n-2)

  ELSE

    F = n

  END IF

END FUNCTION

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n-1)+F(n-1)+G(n-2)

  ELSE

    G = 3-n

  END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1)+G(n-1)+F(n-2)

    else: return n

def G(n):

    if n > 2:

        return G(n-1)+F(n-1)+G(n-2)

    else: return 3-n

Алгоритмический языкПаскаль

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n-1)+G(n-1)+F(n-2)

    иначе

      знач := n

    все

кон

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n-1)+F(n-1)+G(n-2)

    иначе

      знач := 3-n

  все

кон

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n-1)+G(n-1)+F(n-2)

  else

    F := n;

end;

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n-1)+F(n-1)+G(n-2)

  else

    G := 3-n;

end;

Си

int F(int n){

if (n > 2)

return F(n-1)+G(n-1)+F(n-2);

else return n;

}

int G(int n){

if (n > 2)

return G(n-1)+F(n-1)+G(n-2);

else return 3-n;

}

 

 

Чему будет равно значение, вы­чис­лен­ное при вы­пол­не­нии вы­зо­ва F(5)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 21.05.2016 ИН10504.

27
Задание 11 № 11307

Ниже записаны две рекурсивные функции, F и G:

function F(n: integer): integer;

 begin

  if (n > 2) then F := F(n - 1) + G(n - 1) + F(n-2)

 else

F := n;

 end;

function G(n: integer): integer;

 begin

  if (n > 2) then G := G(n - 1) + F(n - 1) + G(n-2)

 else

G := n;

 end;

Чему будет равно значение, вычисленное при выполнении вызова F(5)?

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

28
Задание 11 № 11347

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

БейсикPython

DECLARE SUB F(n)

SUB F(n)

    IF n > 2 THEN

        PRINT n

        F(n - 3)

        F(n – 4)

    END IF

END SUB

def F(n):

    if n > 2:

        print(n)

        F(n - 3)

        F(n – 4)

ПаскальАлгоритмический язык

procedure F(n: integer);

begin

    if n > 2 then begin

        writeln(n);

        F(n - 3);

        F(n – 4)

    end

end;

алг F(цел n)

нач

    если n > 2 то

        вывод n, нс

        F(n - 3)

        F(n – 4)

    все

кон

Си

void F(int n) {

    if (n > 2) {

        printf("%d\n", n);

        F(n - 3);

        F(n – 4);

    }

}

 

 

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(10)?

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

29
Задание 11 № 13357

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

 

БейсикPython

SUB F(n)

  PRINT n,

  IF n >= 3 THEN

    F(n - 1)

    F(n - 3)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 3:

        F(n - 1)

        F(n - 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

begin

  write(n);

  if n >= 3 then

  begin

    F(n - 1);

    F(n - 3)

  end

end;

алг F(цел n)

нач

  вывод n

  если n >= 3 то

    F(n - 1)

    F(n - 3)

  все

кон

Си

void F(int n) {

    printf("%d", n);

    if (n >= 3) {

        F(n - 1);

        F(n - 3);

    }

}

 

 

Что выведет программа при вызове F(5)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

30
Задание 11 № 13407

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

БейсикPython

 FUNCTION F(n)

  IF n > 2 THEN

    F = F(n - 1) +G(n - 2)

  ELSE

     F = 2

  END IF

 END FUNCTION

 

 FUNCTION G(n)

  IF n > 2 THEN

    G = G(n - 1) +F(n - 2)

  ELSE

     G = 2

  END IF

 END FUNCTION

def F(n):

    if n > 2:

      return F(n-1) + G(n-2)

    else: return 2

def G(n):

    if n > 2:

      return G(n-1) + F(n-2)

    else: return 2

ПаскальАлгоритмический язык

function F(n : integer): integer;

 begin

  if n > 2 then

   F := F(n - 1) + G(n - 2)

  else

   F := 2;

 end;

function G(n : integer): integer;

 begin

  if n > 2 then

   G := G(n - 1) + F(n - 2)

  else

   G := 2;

 end;

алг цел F(цел n)

 нач

  если n > 2

  то

    знач:= F(n-1) + G(n-2)

  иначе

    знач:=2

  все

 кон

алг цел G(цел n)

 нач

  если n > 2

  то

    знач:= G(n-1) + F(n-2)

  иначе

    знач:=2

  все

 кон

Си

int F(int n) {

    if (n > 2)

     return F(n-1) + G(n-2);

    else

     return 2;

}

int G(int n) {

    if (n > 2)

     return G(n-1) + F(n-2);

    else

     return 2;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова F(6)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

31
Задание 11 № 13460

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

БейсикPython

 FUNCTION F(n)

  IF n > 2 THEN

    F = F(n - 1) +G(n - 2)

  ELSE

     F = 2

  END IF

 END FUNCTION

 

 FUNCTION G(n)

  IF n > 2 THEN

    G = G(n - 1) +F(n - 2)

  ELSE

     G = 2

  END IF

 END FUNCTION

def F(n):

    if n > 2:

      return F(n-1) + G(n-2)

    else: return 2

def G(n):

    if n > 2:

      return G(n-1) + F(n-2)

    else: return 2

ПаскальАлгоритмический язык

function F(n : integer): integer;

 begin

  if n > 2 then

   F := F(n - 1) + G(n - 2)

  else

   F := 2;

 end;

function G(n : integer): integer;

 begin

  if n > 2 then

   G := G(n - 1) + F(n - 2)

  else

   G := 2;

 end;

алг цел F(цел n)

 нач

  если n > 2

  то

    знач:= F(n-1) + G(n-2)

  иначе

    знач:=2

  все

 кон

алг цел G(цел n)

 нач

  если n > 2

  то

    знач:= G(n-1) + F(n-2)

  иначе

    знач:=2

  все

 кон

Си

int F(int n) {

    if (n > 2)

     return F(n-1) + G(n-2);

    else

     return 2;

}

int G(int n) {

    if (n > 2)

     return G(n-1) + F(n-2);

    else

     return 2;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова G(6)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

32
Задание 11 № 13487

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

БейсикPython

 FUNCTION F(n)

  IF n > 1 THEN

    F = F(n - 1) +G(n - 1)

  ELSE

     F = n

  END IF

 END FUNCTION

 

 FUNCTION G(n)

  IF n > 1 THEN

    G = G(n - 1) +F(n)

  ELSE

     G = n

  END IF

 END FUNCTION

def F(n):

    if n > 1:

      return F(n-1) + G(n-1)

    else: return n

def G(n):

    if n > 1:

      return G(n-1) + F(n)

    else: return n

ПаскальАлгоритмический язык

function F (n : integer) : integer;

 begin

  if n > 1 then

   F := F(n - 1) + G(n - 1)

  else

   F := n;

 end;

function G (n : integer) : integer;

 begin

  if n > 1 then

   G := G(n - 1) + F(n)

  else

   G := n;

 end;

алг цел F(цел n)

 нач

  если n > 1

  то

    знач:= F(n-1) + G(n-1)

  иначе

    знач:=n

  все

 кон

алг цел G(цел n)

 нач

  если n > 1

  то

    знач:= G(n-1) + F(n)

  иначе

    знач:=n

  все

 кон

Си

int F(int n) {

    if (n > 1)

     return F(n-1) + G(n-1);

    else

     return n;

}

int G(int n) {

    if (n > 1)

     return G(n-1) + F(n);

    else

     return n;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова F(5)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

33
Задание 11 № 13514

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

БейсикPython

 FUNCTION F(n)

  IF n > 1 THEN

    F = F(n - 1) +G(n - 1)

  ELSE

     F = n

  END IF

 END FUNCTION

 

 FUNCTION G(n)

  IF n > 1 THEN

    G = G(n - 1) +F(n)

  ELSE

     G = n

  END IF

 END FUNCTION

def F(n):

    if n > 1:

      return F(n-1) + G(n-1)

    else: return n

def G(n):

    if n > 1:

      return G(n-1) + F(n)

    else: return n

ПаскальАлгоритмический язык

function F (n : integer) : integer;

 begin

  if n > 1 then

   F := F(n - 1) + G(n - 1)

  else

   F := n;

 end;

function G (n : integer) : integer;

 begin

  if n > 1 then

   G := G(n - 1) + F(n)

  else

   G := n;

 end;

алг цел F(цел n)

 нач

  если n > 1

  то

    знач:= F(n-1) + G(n-1)

  иначе

    знач:=n

  все

 кон

алг цел G(цел n)

 нач

  если n > 1

  то

    знач:= G(n-1) + F(n)

  иначе

    знач:=n

  все

 кон

Си

int F(int n) {

    if (n > 1)

     return F(n-1) + G(n-1);

    else

     return n;

}

int G(int n) {

    if (n > 1)

     return G(n-1) + F(n);

    else

     return n;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова G(5)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

34
Задание 11 № 13541

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n-1) +G (n-2)

  ELSE

    F = n

  END IF

END FUNCTION

 

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n-1) + F(n-2)

  ELSE

    G = 3-n

  END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n-1) + G(n-2)

    else: return n

def G(n):

    if n > 2:

        return G(n-1) + F(n-2)

    else: return 3-n

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

  if n > 2 then

      F := F(n-1) + G(n-2)

  else

      F := n;

end;

 

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n-1) + F(n-2)

  else

      G := 3-n;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n-1) + G(n-2)

    иначе

      знач := n

  все

кон

 

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n-1) + F(n-2)

    иначе

      знач := 3-n

  все

кон

Си

int F(int n) {

    if (n > 2)

        return F(n-1) + G(n-2);

    else return n;

}

 

int G(int n) {

    if (n > 2)

        return G(n-1) + F(n-2);

    else return 3-n;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова G(6)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

35
Задание 11 № 13568

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

БейсикPython

FUNCTION F(n)

  IF n > 2 THEN

    F = F(n-1) +G (n-2)

  ELSE

    F = n

  END IF

END FUNCTION

 

FUNCTION G(n)

  IF n > 2 THEN

    G = G(n-1) + F(n-2)

  ELSE

    G = 3-n

  END IF

END FUNCTION

def F(n):

  if n > 2:

    return F(n-1) + G(n-2)

  else: return n

 

def G(n):

  if n > 2:

    return G(n-1) + F(n-2)

  else: return 3-n

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

  if n > 2 then

    F := F(n-1) + G(n-2)

  else

    F := n;

end;

 

function G(n: integer): integer;

begin

  if n > 2 then

    G := G(n-1) + F(n-2)

  else

    G := 3-n;

end;

алг цел F(цел n)

нач

  если n > 2

    то

      знач := F(n-1) + G(n-2)

    иначе

      знач := n

  все

кон

 

алг цел G(цел n)

нач

  если n > 2

    то

      знач := G(n-1) + F(n-2)

    иначе

      знач := 3-n

  все

кон

Си

int F(int n) {

  if (n > 2)

    return F(n-1) + G(n-2);

  else return n;

}

 

int G(int n) {

  if (n > 2)

    return G(n-1) + F(n-2);

  else return 3-n;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова F(6)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

36
Задание 11 № 13595

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n - 1) + G(n - 2)

    ELSE

        F = n

    END IF

END FUNCTION

 

FUNCTION G(n)

    IF n > 2 THEN

        G = G(n - 1) + F(n - 2)

    ELSE

        G = n+1

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n - 1)+ G(n - 2)

    else: return n

 

def G(n):

    if n > 2:

        return G(n - 1)+ F(n - 2)

    else: return n+1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n - 1) + G(n - 2)

    else

        F := n;

end;

 

function G(n: integer): integer;

begin

    if n > 2 then

        G := G(n - 1) + F(n - 2)

    else

        G := n+1;

end;

алг цел F(цел n)

нач

    если n > 2

        то

            знач := F(n - 1)+G(n - 2)

        иначе

            знач := n

    все

кон

 

алг цел G(цел n)

нач

    если n > 2

        то

            знач := G(n - 1)+F(n - 2)

        иначе

            знач := n+1

    все

кон

Си

int F(int n)

{

if (n > 2)

return F(n - 1) + G(n - 2);

else return n;

}

int G(int n)

{

if (n > 2)

return G(n - 1) + F(n -2);

else return n+1;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова F(6)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

37
Задание 11 № 13622

Ниже на пяти языках программирования записаны две рекурсивные функции: F и G.

 

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n - 1) + G(n - 2)

    ELSE

        F = n

    END IF

END FUNCTION

 

FUNCTION G(n)

    IF n > 2 THEN

        G = G(n - 1) + F(n - 2)

    ELSE

        G = n+1

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n - 1)+ G(n - 2)

    else: return n

 

def G(n):

    if n > 2:

        return G(n - 1)+ F(n - 2)

    else: return n+1

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n - 1) + G(n - 2)

    else

        F := n;

end;

 

function G(n: integer): integer;

begin

    if n > 2 then

        G := G(n - 1) + F(n - 2)

    else

        G := n+1;

end;

алг цел F(цел n)

нач

    если n > 2

        то

            знач := F(n - 1)+G(n - 2)

        иначе

            знач := n

    все

кон

 

алг цел G(цел n)

нач

    если n > 2

        то

            знач := G(n - 1)+F(n - 2)

        иначе

            знач := n+1

    все

кон

Си

int F(int n)

{

if (n > 2)

return F(n - 1) + G(n - 2);

else return n;

}

int G(int n)

{

if (n > 2)

return G(n - 1) + F(n -2);

else return n+1;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова G(6)?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

38
Задание 11 № 13738

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

 

БейсикPython

DECLARE SUB F(n)

SUB F(n)

    IF n > 0 THEN

        PRINT n

        F(n - 3)

        F(n \ 3)

    END IF

END SUB

def F(n):

    if n > 0:

        print(n)

        F(n - 3)

        F(n // 3)

ПаскальАлгоритмический язык

procedure F(n: integer);

begin

    if n > 0 then begin

        writeln(n);

        F(n - 3);

        F(n div 3)

    end

end;

алг F(цел n)

нач

    если n > 0 то

        вывод n, нс

        F(n - 3)

        F(div(n, 3))

    все

кон

Си++

void F(int n) {

    if (n > 0) {

        std: :cout << n

        F(n - 3);

        F(n / 3);

    }

}

 

 

Запишите подряд без пробелов и разделителей все числа, которые будут напечатаны на экране при выполнении вызова F(9). Числа должны быть записаны в том же порядке, в котором они выводятся на экран.

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

39
Задание 11 № 14226

Ниже на пяти языках программирования записаны рекурсивные функции F и G.

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n - 1) + G(n - 2)

    ELSE

        F = n+1

    END IF

END FUNCTION

 

FUNCTION G(n)

    IF n > 2 THEN

        G = G(n - 1) + F(n - 2)

    ELSE

        G = n

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n - 1)+ G(n - 2)

    else: return n+1

 

def G(n):

    if n > 2:

        return G(n - 1)+ F(n - 2)

    else: return n

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n - 1) + G(n - 2)

    else

        F := n+1;

end;

 

function G(n: integer): integer;

begin

    if n > 2 then

        G := G(n - 1) + F(n - 2)

    else

        G := n;

end;

алг цел F(цел n)

нач

    если n > 2

        то

            знач := F(n - 1)+G(n - 2)

        иначе

            знач := n+1

    все

кон

 

алг цел G(цел n)

нач

    если n > 2

        то

            знач := G(n - 1)+F(n - 2)

        иначе

            знач := n

    все

кон

Си

int F(int n)

{

if (n > 2)

return F(n - 1) + G(n - 2);

else return n+1;

}

int G(int n)

{

if (n > 2)

return G(n - 1) + F(n -2);

else return n;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова F(7)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 14.09.2017 ИН10103

40
Задание 11 № 14270

Ниже на пяти языках программирования записаны рекурсивные функции F и G.

 

БейсикPython

FUNCTION F(n)

    IF n > 2 THEN

        F = F(n - 1) + G(n - 2)

    ELSE

        F = n+1

    END IF

END FUNCTION

 

FUNCTION G(n)

    IF n > 2 THEN

        G = G(n - 1) + F(n - 2)

    ELSE

        G = n

    END IF

END FUNCTION

def F(n):

    if n > 2:

        return F(n - 1)+ G(n - 2)

    else: return n+1

 

def G(n):

    if n > 2:

        return G(n - 1)+ F(n - 2)

    else: return n

ПаскальАлгоритмический язык

function F(n: integer): integer;

begin

    if n > 2 then

        F := F(n - 1) + G(n - 2)

    else

        F := n+1;

end;

 

function G(n: integer): integer;

begin

    if n > 2 then

        G := G(n - 1) + F(n - 2)

    else

        G := n;

end;

алг цел F(цел n)

нач

    если n > 2

        то

            знач := F(n - 1)+G(n - 2)

        иначе

            знач := n+1

    все

кон

 

алг цел G(цел n)

нач

    если n > 2

        то

            знач := G(n - 1)+F(n - 2)

        иначе

            знач := n

    все

кон

Си

int F(int n)

{

if (n > 2)

return F(n - 1) + G(n - 2);

else return n+1;

}

int G(int n)

{

if (n > 2)

return G(n - 1) + F(n -2);

else return n;

}

 

 

Чему будет равно значение, вычисленное при выполнении вызова G(7)?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 14.09.2017 ИН10104

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!