информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Алгоритмы, печатающие числа, наименьшее значение вводимого числа
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 20 № 7677

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 13.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A+1

    B = B + (X MOD 100)

    X = X/100

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 0

while x > 0:

    a = a + 1

    b = b + x%100

    x = x//100

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

        begin

            a := a+1;

            b := b+(x mod 100);

            x := x div 100;

        end;

    writeln(a); write(b);

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x > 0

    a := a+1

    b := b+mod(x,100)

    x := div(x,100)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        a = a+1;

        b = b + (x%100);

        x = x/100;

    }

    cout << a << endl << b endl;

}

 


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 26.11.2014 ва­ри­ант ИН10301.

2
Задание 20 № 7931

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 7.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A+1

    B = B * (X MOD 100)

    X = X\100

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 1

while x > 0:

    a = a + 1

    b = b * x%100

    x = x//100

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

        begin

            a := a+1;

            b := b*(x mod 100);

            x := x div 100;

        end;

    writeln(a); write(b);

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x > 0

    a := a+1

    b := b*mod(x,100)

    x := div(x,100)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        a = a+1;

        b = b * (x%100);

        x = x/100;

    }

    cout << a << endl << b endl;

}

 


Аналоги к заданию № 7931: 3846 7342 4560 7461 Все

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 27.02.2015 ва­ри­ант ИН10901.

3
Задание 20 № 8108

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 3, а потом 6.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

M = M + 1

IF X MOD 2 <> 0 THEN

    L = L + 1

ENDIF

X = X \ 2

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 != 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        M := M + 1;

        if x mod 2 <> 0 then

            L := L + 1;

        x := x div 2;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        M := M + 1

        если mod(x,2) <> 0

            то

                L := L + 1

        все

        x := div(x,2)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        M = M + 1;

        if(x % 2 != 0){

            L = L + 1;

        }

        x = x / 2;

    }

    cout << L << endl << M endl;

}

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

4
Задание 20 № 8668

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает числа: a и b.

Укажите наименьшее положительное пятизначное число x, при котором после выполнения алгоритма будет напечатано сначала 4, а потом 2.

 

Бейсик Python

DIM X, Y, A, B AS INTEGER

A = 0

B = 0

INPUT X

WHILE X > 0

    Y = X MOD 10

    IF Y > 3 THEN A = A + 1

    IF Y < 8 THEN B = B + 1

    X = X \ 10

WEND

PRINT A

PRINT B

a = 0

b = 0

x = int(input())

while x > 0:

    y = x % 10

    if y > 3:

        a = a+1

    if y < 8:

        b = b+1

    x = x // 10

print(a)

print(b)

Алгоритмический языкПаскаль

алг

нач

    цел x, y, a, b

    a := 0

    b := 0

    ввод x

    нц пока x > 0

        y := mod(x, 10)

        если y > 3

            то a := a + 1

        все

        если y < 8

            то b := b + 1

        все

        x := div(x, 10)

    кц

    вывод a, нс, b

кон

var x, y, a, b: integer;

begin

    a := 0;

    b := 0;

    readln(x);

    while x > 0 do

    begin

        y := x mod 10;

        if y > 3 then

            a := a + 1;

        if y < 8 then

            b := b + 1;

        x := x div 10

    end;

    writeln(a);

    writeln(b)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, y, a, b;

    a = 0;

    b = 0;

    cin >> x;

    while (x > 0)

    {

        y = x % 10;

        if (y > 3)

            a = a + 1;

        if (y < 8)

            b = b + 1;

        x = x / 10;

    }

    cout << a << endl << b << endl;

}

 


Аналоги к заданию № 8668: 9172 Все

Источник: СтатГрад: Ре­пе­ти­ци­он­ная ра­бо­та по ин­фор­ма­ти­ке 01.04.2015 ИН10701
Пояснение · ·

5
Задание 20 № 9204

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 11.

Бейсик Python

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A+1

    B = B*(X MOD 1000)

    X = X\1000

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 1

while x > 0:

    a = a+1

    b = b*x%1000

    x = x//1000

print(a)

print(b)

Алгоритмический язык Паскаль

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        a := a+1

        b := b*mod(x, 1000)

        x := div(x, 1000)

    кц

    вывод a, нс, b

кон

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

    begin

        a := a+1;

        b := b*(x mod 1000);

        x := x div 1000;

    end;

    writeln(a); write(b);

end.

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        a = a+1;

        b = b * (x%1000);

        x = x/1000;

    }

    cout << a << endl << b endl;

    return 0;

}

 


Аналоги к заданию № 9204: 7310 9312 Все

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 06.05.2015 ИН10801

6
Задание 20 № 9371

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т.е. большее 100) число x, при вводе которого алгоритм печатает 26.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = X

M = 65

IF L MOD 2 = 0 THEN

    M = 52

ENDIF

WHILE L <> M

IF L > M THEN

    L = L – M

ELSE

    M = M – L

ENDIF

WEND

PRINT M

x = int(input())

L = x

M = 65

if L % 2 == 0:

    M = 52

while L != M:

    if L > M:

        L = L - M

    else:

        M = M - L

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := x;

    M := 65;

    if L mod 2 = 0 then

        M := 52;

    while L <> M do

        if L > M then

            L := L - M

        else

            M := M – L;

    writeln(M);

end.

 

алг

нач

    цел x, L, M

    ввод x

    L := x

    M := 65

    если mod(L,2)=0

        то

            M := 52

    все

    нц пока L <> M

        если L > M

            то

                L := L – M

            иначе

                M := M – L

        все

    кц

    вывод M

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = x;

    M = 65;

    if (L % 2 == 0)

        M = 52;

    while (L != M){

        if(L > M)

            L = L - M;

        else

            M = M - L;

    }

    cout « M « endl;

}

 


Аналоги к заданию № 9371: 10483 10510 Все

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

7
Задание 20 № 9655

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 48, а потом 6.

 

БейсикПаскаль

DIM X, A, B, C AS INTEGER

INPUT X

A = 1: B = 0

WHILE X > 0

  C = X MOD 10

  A = A * C

  IF C > B THEN B = C

  X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b, c: integer;

begin

  readln(x);

  a := 1; b := 0;

  while x>0 do

  begin

    c := x mod 10;

    a := a*c;

    if c>b then b := c;

    x := x div 10;

  end;

  writeln(a); write(b);

end.

Си++Алгоритмический язык

 

#include <iostream>

using namespace std;

int main()

{

  int x, a, b, c;

  cin >> x;

  a = 1; b = 0;

  while (x>0) {

    c = x%10;

    a = a*c;

    if (c>b)

      b = c;

    x = x/10;

  }

  cout << a << endl << b endl;

}

алг

нач

  цел x, a, b, c

  ввод x

  a := 1; b := 0

  нц пока x>0

    c := mod(x,10)

    a := a*c

    если c>b

      то b := c

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Python

x = int(input())

a = 1

b = 0

while x > 0:

    c = x % 10

    a = a*c

    if c > b:

        b = c

    x //= 10

print(a)

print(b)

 


Аналоги к заданию № 9655: 9701 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.09.2015 ИН10103

8
Задание 20 № 9770

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 30.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = X - 30

M = X + 30

WHILE L <> M

   IF L > M THEN

    L = L – M

  ELSE

    M = M – L

END IF

WEND

PRINT M

x = int(input())

L = x-30

M = x+30

while L != M:

  if L > M:

    L = L - M

  else:

    M = M - L

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

  readln(x);

  L := x-30;

  M := x+30;

  while L <> M do

    if L > M then

      L := L - M

    else

      M := M – L;

  writeln(M);

end.

алг

нач

  цел x, L, M

  ввод x

  L := x-30

  M := x+30

  нц пока L <> M

    если L > M

      то

      L := L – M

      иначе

      M := M – L

    все

  кц

  вывод M

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, L, M;

  cin >> x;

  L = x-30;

  M = x+30;

  while (L != M){

    if(L > M)

      L = L - M;

    else

      M = M - L;

  }

  cout « M « endl;

  return 0;

}

 


Аналоги к заданию № 9770: 9806 11249 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 02.12.2015 ИН10203

9
Задание 20 № 7765

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает числа: a и b. Укажите наименьшее положительное пятизначное число x, при вводе которого алгоритм печатает сначала 6, а потом 3.

 

БейсикPython

DIM X, Y, A, B AS INTEGER

A = 0

B = 10

INPUT X

WHILE X > 0

    Y = X MOD 10

    X = X \ 10

    IF Y > A THEN A = Y

    IF Y < B THEN B = Y

WEND

PRINT A

PRINT B

a = 0

b = 10

x = int(input())

while x > 0:

    y = x % 10

    x = x // 10

    if y > a:

        a = y

    if y < b:

        b = y

print(a)

print(b)

ПаскальАлгоритмический язык

var x, y, a, b: integer;

begin

    a := 0;

    b := 10;

    readln(x);

    while x > 0 do

        begin

            y := x mod 10;

            x := x div 10

            if y > a then

                    a := y;

            if y < b then

                    b := y;

        end;

writeln(a);

writeln(b)

end.

алг

нач

цел x, y, a, b

a := 0

b := 10

ввод x

нц пока x > 0

y := mod(x, 10)

x := div(x, 10)

если y > a

то a := y

все

если y < b

то b := y

все

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, y, a, b;

    a = 0;

    b = 10;

    cin >> x;

    while (x > 0)

    {

        y = x % 10;

        x = x / 10;

        if (y > a)

            a = y;

        if (y < b)

            b = y;

    }

    cout << a << endl << b << endl;

}

 

Источник: СтатГрад: Диагностическая работа по ин­фор­ма­ти­ке 26.01.2015 ва­ри­ант ИН10501.
Пояснение · ·

10
Задание 20 № 3259

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 0.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF X MOD 2 = 0 THEN

    M = M + x mod 10

x = x \ 10

ENDIF

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L += 1

    if x % 2 == 0:

        M = M + x % 10

    x //= 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 0 then

            M := M + x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 0

            то

                M := M + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 0){

            M = M + x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 


Аналоги к заданию № 3259: 3275 Все

Пояснение · ·

11
Задание 20 № 3260

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF M < x AND x mod 2 = 0 THEN

     M = x mod 10

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if M < x and x % 2 == 0:

        M = x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if (M < x) and (x mod 2 = 0) then

            M:=x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если M < x и mod(x,2) = 0 то

            M := mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(M < x and x % 2 == 0){

            M = x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 

Пояснение · ·

12
Задание 20 № 3261

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 72.

 

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A + 1

    B = B * (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b : integer;

begin

readln(x);

a := 0; b := 1;

while x > 0 do

    begin

        a := a + 1;

        b := b * (x mod 10);

        x := x div 10;

    end;

writeln(a); write(b);

end.

Си++ Алгоритмический
#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a + 1;

        b = b *(x%10);

        x= x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 1

нц пока x > 0

    a := a+1

    b := b * mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)

 


Аналоги к заданию № 3261: 3266 3276 3277 Все


13
Задание 20 № 3265

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF x mod 2 = 1 THEN

     M = M + (x mod 10) \ 2

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if x % 2 == 1:

        M = M + (x % 10) // 2

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if (x mod 2 = 1) then

            M:= M + (x mod 10) div 2;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 1 то

            M := M + div(mod(x,10), 2)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 1){

            M = M + (x % 10) / 2;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 


14
Задание 20 № 3270

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 28.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF M < x THEN

     M = M + (x mod 10) * 2

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if M < x:

        M = M + (x % 10) * 2

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if M < x then

            M:= M + (x mod 10) * 2;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если M < x то

            M := M + mod(x,10) * 2

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(M < x){

            M = M + (x % 10) * 2;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 


15
Задание 20 № 3274

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF x mod 2 = 0 THEN

     M = M + x mod 10

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if x % 2 == 0:

        M = M + x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 0 then

            M:= M + x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 0 то

            M := M + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 0){

            M = M + x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 


Аналоги к заданию № 3274: 3280 Все

Пояснение · ·

16
Задание 20 № 3279

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF M < x THEN

     M = x mod 10

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if M < x:

        M = x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if M < x then

            M:= x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если M < x то

            M := mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(M < x){

            M = x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 


17
Задание 20 № 4560

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 21.

 

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=1;

    while (x>0){

        a=a+1;

        b=b*(x%10);

        x= x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= (x % 10)

    x //= 10

print(a)

print(b)

 


18
Задание 20 № 4980

Ниже на 4-х языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 6, а потом 9.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A + 2

    B = B + (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x>0 do

        begin

            a := a + 2;

            b := b + (x mod 10);

            x:= x div 10;

        end;

    writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0){

        a = a + 2;

        b = b + (x%10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x > 0

    a := a + 2

    b := b+mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 2

    b += (x % 10)

    x //= 10

print(a)

print(b)

 


19
Задание 20 № 5215

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число N, этот алгоритм печатает число q. Укажите наименьшее из таких чисел N, при вводе которых алгоритм напечатает 17.

 

 

БейсикПаскаль

DIM N, q, i AS INTEGER

INPUT N

FOR i = 1 TO N - 1

    IF N MOD i = 0 THEN q = i

NEXT i

PRINT q

var N, q, i: integer;

begin

    read(N);

    for i : = 1 to N - 1 do begin

        if N mod i = 0 then q : = i

    end;

    write(q)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int N, q, i;

    cin >> N;

    for (i = 1; i <= N - 1; i++) {

        if (N%i == 0) q = i;

    }

    cout « q « endl;

}

алг

нач

цел N, q, i

ввод N

нц для i от 1 до N - 1

    если mod(N, i) = 0

        то q : = i все

кц

вывод q

кон

Python

n = int(input())

for i in range(1, n):

    if n % i == 0:

        q = i

print(q)

 


Аналоги к заданию № 5215: 5247 Все

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1502.

20
Задание 20 № 5460

Ниже на четырёх языках записан алгоритм. Получив на вход число , этот алгоритм печатает два числа: и . Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 2, а потом 3. Допускается диапазон значений для величин целого типа: от −231 до 231 — 1.

 

БейсикПаскаль

DIM X, А, В, С AS INTEGER

INPUT X

А = 0: В = 0

WHILE X > 0

    С = X MOD 2

    IF C = 0 THEN

        A = A + 1

    ELSE

        B = B + 1

    END IF

    X = X \ 10

WEND

PRINT А

PRINT В

var x, a, b, c: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x>0 do

        begin

            с := x mod 2;

            if c = 0 then

                a := a + 1

            else

                b := b + 1

            x := x div 10

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0;

    b = 0;

    while (x > 0) {

        с = x % 2;

        if (c == 0) a = a + 1;

        else b = b + 1;

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, а, b, с

ввод X

а := 0; b := 0

нц пока х>0

    с := mod(х, 2)

    если с = 0

        то a := a + 1

    иначе b := b + 1

все

х := div(х, 10)

кц

вывод а, не, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    с = x % 2

    if c == 0:

        a += 1

    else:

        b += 1

    x //= 10

print(a)

print(b)

 


Аналоги к заданию № 5460: 5588 5620 5652 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 1.
Пояснение · ·

21
Задание 20 № 5492

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 11, а потом 5.

 

 

БейсикПаскаль

DIM X, А, В, С AS INTEGER

INPUT X

А = 0: В = 10

WHILE X > 0

    С = X MOD 10

    А = А + С

    IF С < В THEN В = С

    X = X \ 10

WEND

PRINT А

PRINT В

var x, a, b, c: integer;

begin

    readln(x);

    a := 0; b := 10;

    while x>0 do

        begin

            с := x mod 10;

            a := a+c;

            if c < b then b := c;

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0;

    b = 10;

    while (x > 0) {

        с = x%10;

        a = a+c;

        if (c < b)

            b = c;

        x = x /10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, а, b, с

ввод X

а := 0; b := 10

нц пока х>0

    с := mod(х, 10)

    а := а+с

    если с < b

        то b := с

все

х := div(х, 10)

кц

вывод а, не, b

кон

Python

x = int(input())

a = 0

b = 10

while x > 0:

    с = x % 10

    a += c

    if c < b:

        b = c

    x //= 10

print(a)

print(b)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 1.

22
Задание 20 № 6006

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 13, а потом 5.

 

БейсикПаскаль

DIM X, A, B, C AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    C = X MOD 10

    A = A + C

    IF C < B THEN B = C

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b, c: integer;

begin

    readln(x);

    a := 0; b := 10;

    while x>0 do

        begin

            c := x mod 10;

            a := a+c;

            if c < b then b := c;

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0; b = 10;

    while (x>0) {

        c = x%10;

        a = a+c;

        if (c<b)

            b = c;

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b, c

ввод x

a := 0; b := 10

нц пока x>0

    c := mod(x,10)

    a := a+c

    если c<b

        то b := c

    все

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 10

while x > 0:

    с = x % 10

    a += c

    if c < b:

        b = c

    x //= 10

print(a)

print(b)

 


23
Задание 20 № 6781

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 2.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=0

WHILE X > 0

    A = A+1

    IF B < (X MOD 8) THEN

        B = X MOD 8

    END IF

    X = X \ 8

WEND

PRINT A

PRINT B

var x, a, b: integer;

    begin

    readln(x);

    a:=0; b:=0;

    while x>0 do

        begin

            a:=a + 1;

            if b < (x mod 8)

            then

                b:=x mod 8;

            x:=x div 8;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=0;

    while (x>0){

        a = a+1;

        if (b < (x%8){

            b = x%8;

        }

        x = x/8;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x>0

    a:=a+1

    если b < mod(x,8)

        то

            b:=mod(x,8)

    все

    x:=div(x,8)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    if b < (x % 8):

        b =x % 8

    x //= 8

print(a)

print(b)

 


Аналоги к заданию № 6781: 6813 Все

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 20.02.2014 ва­ри­ант ИН10601.

24
Задание 20 № 6960

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает

сначала 3, а потом 25.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A + 1

    IF (X MOD 2) <> 0 THEN

        B = B+(X MOD 10)

    END IF

    X = X\10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

        begin

            a := a + 1;

            if(x mod 2) <> 0 then

                b := b+(x mod 10);

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0){

        a = a+1;

        if ((x%2)!=0){

            b = b+(x%10);

        }

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 0

нц пока x > 0

    a := a+1

    если mod(x,2) <> 0 то

        b := b+mod(x,10)

    все

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    if (x % 2) != 0:

        b += (x % 10)

    x //= 10

print(a)

print(b)

 

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.03.2014 Ва­ри­ант ИНФ10801.

25
Задание 20 № 7274

Ниже записана программа. Получив на вход число , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 8.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF X MOD 2 = 1 THEN

    M = M + X MOD 10

ENDIF

X = X \ 10

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L += 1

    if x % 2 == 1:

        M = M + x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 1 then

            M := M + x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 1

            то

                M := M + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 1){

            M = M + x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M << endl;

}

 


26
Задание 20 № 7461

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 15.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0

b = 1

while x > 0:

    a = a + 1

    b = b * (x % 10)

    x = x // 10

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10

        end;

    writeln(a); write(b)

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 1;

    while (x > 0){

        a = a + 1;

        b = b * (x % 10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

 


27
Задание 20 № 10296

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 20.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

  A = A + 1

  IF (X MOD 2) = 0 THEN

    B = B+(X MOD 10)

  END IF

  X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x>0:

  a=a+1

  if x%2==0:

    b += x%10

  x = x//10

print(a)

print(b)

ПаскальАлгоритмический язык

program B20;

var x, a, b: integer;

begin

  readln(x);

  a:= 0; b:= 0;

  while x > 0 do

  begin

    a:= a + 1;

    if x mod 2 = 0 then

      b:= b+ x mod 10;

    x:=x div 10;

  end;

  writeln(a); write(b);

end.

алг

нач

  цел x, a, b

  ввод x

  a := 0; b := 0

  нц пока x > 0

    a := a+1

    если mod(x,2)=0 то

      b := b + mod(x,10)

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, a, b;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    a = a+1;

    if (x%2 == 0) {

      b = b+x%10;

    }

    x = x / 10;

  }

  cout << a << endl << b << endl;

  return 0;

}

 


Аналоги к заданию № 10296: 10394 10421 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10303

28
Задание 20 № 10323

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 18.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

  A = A + 1

  IF (X MOD 2) = 0 THEN

    B = B+(X MOD 10)

  END IF

  X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x>0:

  a=a+1

  if x%2==0:

    b += x%10

  x = x//10

print(a)

print(b)

ПаскальАлгоритмический язык

program B20;

var x, a, b: integer;

begin

  readln(x);

  a := 0; b := 0;

  while x > 0 do

  begin

    a := a + 1;

    if x mod 2 = 0 then

      b := b+ x mod 10;

    x := x div 10;

  end;

  writeln(a); write(b);

end.

алг

нач

  цел x, a, b

  ввод x

  a := 0; b := 0

  нц пока x > 0

    a := a+1

    если mod(x,2)=0 то

      b := b + mod(x,10)

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, a, b;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    a = a+1;

    if (x%2 == 0) {

      b = b+x%10;

    }

    x = x / 10;

  }

  cout << a << endl << b endl;

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10304

29
Задание 20 № 11276

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 60.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = X - 30

M = X + 30

WHILE L <> M

  IF L > M THEN

    L = L – M

  ELSE

    M = M – L

  END IF

WEND

PRINT M

x = int(input())

L = x-30

M = x+30

while L != M:

    if L > M:

        L = L - M

    else:

        M = M - L

print(M)

Алгоритмический языкПаскаль

алг

нач

цел x, L, M

ввод x

L := x-30

M := x+30

нц пока L <> M

если L > M

то L := L – M

иначе M := M – L

все

кц

вывод M

кон

var x, L, M: integer;

begin

  readln(x);

  L := x-30;

  M := x+30;

  while L <> M do begin

    if L > M

      then L := L - M

      else M := M – L;

  end;

  writeln(M);

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, L, M;

  cin >> x;

  L = x-30;

  M = x+30;

  while (L != M) {

    if(L > M) L = L - M;

    else M = M - L;

  }

  cout « M « endl;

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 21.05.2016 ИН10504.

30
Задание 20 № 11356

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 16. Если таких чисел x несколько, укажите наименьшее из них.

 

БейсикPython

DIM X,D,R AS LONG

INPUT X

R = 0

WHILE X>0

    D = X MOD 10

    R = 10*R + D

    X = X \ 10

WEND

PRINT R

x = int(input())

R = 0

while x>0:

    d = x % 10

    R = 10*R + d

    x = x // 10

print(R)

ПаскальАлгоритмический язык

var

    x,d,R: longint;

begin

    readln(x);

    R := 0;

    while x>0 do

        begin

            d := x mod 10;

            R := 10*R + d;

            x := x div 10

        end;

    writeln(R)

end.

алг

нач

    цел x, d, R

    ввод x

    R := 0

    нц пока x>0

        d := mod(x, 10)

        R := 10*R + d

        x := div(x, 10)

    кц

    вывод R

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    long x,d,R;

    cin >> x;

    R = 0;

    while (x>0)

        {

            d = x % 10;

            R = 10*R + d;

            x = x / 10;

        }

    cout << R << endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

31
Задание 20 № 13416

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 14.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0

B = 0

WHILE X > 0

  A = A + 1

  IF X MOD 2 = 0 THEN

   B = B + X MOD 10

   END IF

   X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0; b = 0

while x > 0:

  a = a + 1

  if (x % 2 ==0):

    b += x%10

  x=x / / 10

print(a, b)

ПаскальАлгоритмический язык

program b20;

var x, a, b: integer;

begin

    readln(x);

    a := 0

    b := 0;

    while x > 0 do

    begin

      a := a + 1;

      if x mod 2 = 0 then

         b := b + x mod 10;

       x := x div 10;

    end;

    writeln(a);

    write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0

    b := 0

    нц пока x > 0

        a := a + 1

        если mod(x,2)=0 то

          b := b + mod(x,10)

         все

         x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 0;

    while (x > 0){

        a = a + 1;

         if (x%2 == 0) {

           b = b+x%10;

        }

        x = x / 10

      }

    cout << a << endl << b endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

32
Задание 20 № 13469

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 16

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0

B = 0

WHILE X > 0

  A = A + 1

  IF X MOD 2 = 0 THEN

   B = B + X MOD 10

   END IF

   X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0; b = 0

while x > 0:

  a = a + 1

  if (x % 2 ==0):

    b += x%10

  x=x / / 10

print(a, b)

ПаскальАлгоритмический язык

program b20;

var x, a, b: integer;

begin

    readln(x);

    a := 0

    b := 0;

    while x > 0 do

    begin

      a := a + 1;

      if x mod 2 = 0 then

         b := b + x mod 10;

       x := x div 10;

    end;

    writeln(a);

    write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0

    b := 0

    нц пока x > 0

        a := a + 1

        если mod(x,2)=0 то

          b := b + mod(x,10)

         все

         x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 0;

    while (x > 0){

        a = a + 1;

         if (x%2 == 0) {

           b = b+x%10;

        }

        x = x / 10

      }

    cout << a << endl << b endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

33
Задание 20 № 13496

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число S. Укажите такое наименьшее число x, при вводе которого алгоритм печатает шестизначное число.

 

БейсикPython

DIM X,S,D,R AS LONG

INPUT X

S = X

R = 0

WHILE X > 0

  D = X MOD 2

  R = 10*R + D

   X = X \ 2

WEND

S = R + S

PRINT S

x = int(input())

S = x;

R = 0

while x > 0:

   d = x % 2

   R = 10*R + d

  x=x / / 2

S = R + S

print(S)

ПаскальАлгоритмический язык

var x,d,R,S: longint;

begin

     readln(x);

     S := x;

     R := 0;

     while x > 0 do

     begin

       d := x mod 2;

       R := 10*R + d;

       x := x div 2;

     end;

     S := R + S;

     writeln(S);

end.

алг

нач

     цел x, d, R, S

     ввод x

     S := x

     R := 0

     нц пока x > 0

         d := mod(x, 2)

         R := 10*R + d

         x := div(x, 2)

     кц

     S := R + S

    вывод S

кон

Си++

#include <iostream>

using namespace std;

int main()

{

     long x,d,R,S;

     cin >> x;

     S = x;

     R = 0;

     while (x > 0){

         d = x % 2;

         R = 10*R + d;

         x = x / 2;

       }

     S = R + S

     cout << S << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

34
Задание 20 № 13523

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число S. Укажите такое наименьшее число x, при вводе которого алгоритм печатает пятизначное число.

 

БейсикPython

DIM X,S,D,R AS LONG

INPUT X

S = X

R = 0

WHILE X > 0

  D = X MOD 2

  R = 10*R + D

   X = X \ 2

WEND

S = R + S

PRINT S

x = int(input())

S = x;

R = 0

while x > 0:

   d = x % 2

   R = 10*R + d

  x=x / / 2

S = R + S

print(S)

ПаскальАлгоритмический язык

var x,d,R,S: longint;

begin

     readln(x);

     S := x;

     R := 0;

     while x > 0 do

     begin

       d := x mod 2

       R := 10*R + d;

       x := x div 2

     end;

     S := R + S

     writeln(s);

end.

алг

нач

     цел x, d, R, S

     ввод x

     S := x

     R := 0

     нц пока x > 0

         d := mod(x, 2)

         R := 10*R + d

         x := div(x, 2)

     кц

     S := R + S

    вывод S

кон

Си++

#include <iostream>

using namespace std;

int main()

{

     long x,d,R,S;

     cin >> x;

     S = x;

     R = 0;

     while (x > 0){

         d = x % 2;

         R = 10*R + d;

         x = x / 2;

       }

     S = R + S

     cout << S << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

35
Задание 20 № 13550

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 150. Укажите наименьшее такое (т. е. большее 150) число x, при вводе которого алгоритм печатает 30.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 2*X-30

M = 2*X+30

WHILE L <> M

  IF L > M THEN

    L = L - M

  ELSE

    M = M - L

  END IF

WEND

PRINT M

x = int(input())

L = 2*x-30

M = 2*x+30

while L != M:

  if L > M:

    L = L - M

  else:

    M = M - L

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

  readln(x);

  L := 2*x-30;

  M := 2*x+30;

  while L <> M do begin

    if L > M then

      L := L - M

    else

      M := M - L;

  end;

  writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 2*x-30

    M := 2*x+30

    нц пока L <> M

      если L > M

        то

          L := L - M

        иначе

          M := M - L

      все

    кц

    вывод M

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 2*x-30;

    M = 2*x+30;

    while (L != M) {

      if (L > M)

        L = L - M;

      else

        M = M - L;

    }

    cout « M « endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

36
Задание 20 № 13577

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 30.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 2*X-30

M = 2*X+30

WHILE L <> M

  IF L > M THEN

    L = L - M

  ELSE

    M = M - L

  END IF

WEND

PRINT M

x = int(input())

L = 2*x-30

M = 2*x+30

while L != M:

  if L > M:

    L = L - M

  else:

    M = M - L

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

  readln(x);

  L := 2*x-30;

  M := 2*x+30;

  while L <> M do begin

    if L > M then

      L := L - M

    else

      M := M - L;

  end;

  writeln(M);

end.

алг

нач

  цел x, L, M

  ввод x

  L := 2*x-30

  M := 2*x+30

  нц пока L <> M

    если L > M

      то

        L := L - M

      иначе

        M := M - L

    все

  кц

  вывод M

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, L, M;

  cin >> x;

  L = 2*x-30;

  M = 2*x+30;

  while (L != M) {

    if (L > M)

      L = L - M;

    else

      M = M - L;

  }

  cout « M « endl;

  return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

37
Задание 20 № 13604

Ниже на различных языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Сколько существует таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 24?

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

A = A + 1

B = B*(X MOD 10)

X = X\10

WEND

PRINT A

PRINT B

x=int(input())

a=0; b=1

while x>0:

    a=a+1

    b=b*(x%10)

    x=x//10

print(a,"\n",b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

     while x > 0 do

    begin

        a := a+1;

        b := b*(x mod 10);

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        a := a+1

        b := b*mod(x,10)

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a+1;

        b = b*(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

38
Задание 20 № 13631

Ниже на различных языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Сколько существует таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 0?

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

A = A + 1

B = B*(X MOD 10)

X = X\10

WEND

PRINT A

PRINT B

x=int(input())

a=0; b=1

while x>0:

    a=a+1

    b=b*(x%10)

    x=x//10

print(a,"\n",b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

     while x > 0 do

    begin

        a := a+1;

        b := b*(x mod 10);

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        a := a+1

        b := b*mod(x,10)

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a+1;

        b = b*(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

39
Задание 20 № 13747

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 5, а потом 7.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

     IF X MOD 2 <> 0 THEN

      L = L + 1

     END IF

X = X \ 2

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

     M = M + 1

     if x % 2 != 0:

      L = L + 1

     x = x // 2

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

     readln(x);

     L := 0;

     M := 0;

     while x>0 do

    begin

          M := M + 1;           if x mod 2 <> 0 then

            L := L + 1;

          x := x div 2;

    end;

    writeln(L)

    writeln(M)

end.

алг

нач

     цел x, L, M

     ввод x

     L := 0

     M := 0

    нц пока x > 0

        M := M + 1

         если mod(x,2) <> 0

            то

             L := L + 1

        все

        x := div(x,2)

     кц

     вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main(){

     int x, L, M;

     cin >> x;

     L = 0;

     M = 0;

     while (x > 0) {

          M = M + 1;

          if(x % 2 != 0) {

             L = L + 1;

          }

          x = x / 2;

        }

        cout << L << endl << M << endl;

        return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

40
Задание 20 № 14781

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 4.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 10

    END IF

    X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%10

    x = x//10

print(a, b)

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

    begin

        if x mod 2= 0 then

            a := a + 1

        else

            b := b + x mod 10;

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0) a += 1;

        else b += x%10;

        x = x / 10;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 28.11.2017 ИН10204

41
Задание 20 № 15115

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 4.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 6

    END IF

    X = X \ 6

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%6

    x = x//6

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do begin

        if x mod 2 = 0 then

            a := a + 1

        else

            b := b + x mod 6;

        x := x div 6;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,6)

        все x := div(x,6)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0) a += 1;

        else                

        b += x%6;

        x = x / 6;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 17.01.2018 ИН10301

42
Задание 20 № 15142

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 1, а потом 6.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 6

    END IF

    X = X \ 6

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%6

    x = x//6

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do begin

        if x mod 2 = 0 then

            a := a + 1

        else

            b := b + x mod 6;

        x := x div 6;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,6)

        все x := div(x,6)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0)

        a += 1;

        else                

        b += x%6;

        x = x / 6;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 17.01.2018 ИН10302

43
Задание 20 № 15636

Укажите наибольшее десятичное число, при вводе которого на экране сначала напечатается 3, а затем 6.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF X MOD 2 <> 0 THEN

    M = M + (X MOD 8)

ENDIF

X = X \ 8

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0 :

    L = L+1

     if (x % 2) != 0:

         M = M + x % 8

     x = x // 8

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L:=0; M:=0;

    while x > 0 do begin

         L:=L + 1;

        if (x mod 2) <> 0 then

             M:= M + x mod 8;

        x:= x div 8;

    end;

    writeln(L); write(M);

end.

алг

нач

     цел x, L, M

     ввод x

     L := 0

     M := 0

    нц пока x > 0

        L := L + 1

         если mod(x,2) <> 0

            то

             M:= M + mod (x,8);

        x := div(x,8)

        все

     кц

     вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main(void) {

    int L, M, x;

    cin >> x;

     L = 0; M = 0;

    while (x > 0) {

         L = L + 1;

        if (x % 2 != 0) {

             M = M + x % 8;

        }

        x = x / 8;

    }

     cout << L << “ “ << M;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна

44
Задание 20 № 15860

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное десятичное число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 14, а потом 3.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 <> 0 THEN

        L = L + X MOD 8

    ENDIF

    X = X \ 8

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0 :

    M = M+1

     if (x % 2) != 0:

         L = L + x % 8

     x = x // 8

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L:=0; M:=0;

    while x > 0 do begin

        M:=M + 1;

        if (x mod 2) <> 0 then

            L:= L + x mod 8;

        x:= x div 8;

    end;

    writeln(L); write(M);

end.

алг

нач

     цел x, L, M

     ввод x

     L := 0

     M := 0

    нц пока x > 0

        M := M + 1

         если mod(x,2) <> 0

            то

             L:= L + mod (x,8);

        x := div(x,8)

        все

     кц

     вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main(void) {

    int L, M, x;

    cin >> x;

     L = 0; M = 0;

    while (x > 0) {

         M = M + 1;

        if (x % 2 != 0) {

             L = L + x % 8;

        }

        x = x / 8;

    }

     cout << L << “ “ << M;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна Вариант 2

Пройти тестирование по этим заданиям